• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

634 USB Probs, getting desparate...

Vinz

New member
Hi everyone.
new to this forum.

I got a problem with my CF 634 USB LCD. I got it like a year ago and it worked great then. But after a period I disconnected it because I was into case modding then and I didn’t wanted to damage it. Today i did a format and decided to connect my LCD back on.

I installed the USB drivers (v2134). Followed the installation of the LCD and USB in Win XP like explained in the installation guide and i connected the LCD.
The LCD lighted up and there were all white dots with these signs in it: "}}}}}}" I installed Jalcds and gave that a try. The information came on the display except when it was finished scrolling, the text began to shake a lot. It switched lines all the times.

So I searched on this forum but didn’t find anything that could help me, so I tried to install the newer USB drivers (v 2153 I believe). Now the whole LCD is messed up badly, it doesn’t do anything anymore. It even won’t light up when connecting or anything. I checked device manager there wasn’t any device connected anymore to COM3. I don’t' understand a thing anymore, so I deleted the new driver and putted v2134 back on, still not working. I uninstalled port95nt and installed it again, still not working. I don’t know what to do. I just hope I won’t have to format my pc again to get it working.

Plz anyone help me... I would appreciate it A LOT!!

Tnx, Vinz
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

Vinz

New member
Maybe I should mention my configuration:
AMD 2100+ @ 2233Mhz
Asus A7N8X nforce² motherboard.
ATI Radeon 9500 Pro
Win XP Pro
2*Seagate Barracuda V ATA

I don’t know if its important, but the 2 switches on the back of the LCD with "SW1" written on it or in the ON position.

Tnx
 

Vinz

New member
Thanks a lot CF Tech, your explanation helped me a lot further. I got it all working now.

What did I do?:

I went to device manager, and saw that there was not a CF LCD @ COM3 (like in your picture, the first pink mark). Then I checked if there was a CF LCD at the USB (like in your second pink mark). There was one, except that it had an exclamation mark next to it and it said the drivers could not appropriately be loaded (sorry for my English, my win XP is in Dutch..), so I right mouse clicked on it and deleted it.

Then I disconnected the LCD and uninstalled all the drivers. Then rebooted and installed them again. Then I connected the LCD and windows gave me 2 times the pop up menu "new hardware" (once for CF LCD and once for USB). So I installed them like described in the explanation (this: http://www.crystalfontz.com/software/usb/step1.php)

And now I installed JALCDS again and working great.

So thanks a lot mate, you really helped me out, thanks!!
 
Top