• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

My 634 USB problem

ratz34

New member
I've seen this posted before but it seams that they have been lacking in detail so i'm going to post my version of the 634 USB.

To start off with the 634 USB is plugged straight into the back of the tower in to the Motherboard.

The first time I install the 634 USB it works fine. The problem starts when the pc gets turned off or restarted. After this the CrystalControl software will do one of 2 things. Return a "Stack Overflow" or the CrystalControl software will load but will prompt a message stating that - COM port 3 cannot be initialized - . Wintest prompts a message saying "Could not open any of the serial ports."

After all this I can get it to work "IF / WHEN" (pick a word you want) I unplug the 634 USB cable, wait a few seconds and plug it back in. Then it works fine. Or boot the pc with out the 634 USB plugged in and then plug in the USB cable after I get into windows.

If I'm right this problem did not start for me until after I updated windows xp to the version that prompts you to select a user when windows start. Before windows loaded into the default user, but now (with the current XP updates) forces you to select a user to boot into the desktop. I'm sure that there is a way to disable this.

It would be interesting to see if you can force the drivers NOT to load until after the desktop is loaded and then have the drivers call for the CrystalControl software.

ASUS P4C800 Deluxe Bios ver 1008.004
Intel P4 2.8 HT PAT
2 x 512 Kingston Hyper X
ATi 9700 Pro
2 x Seagate Barracuda ATA V in Raid 0
Windows XP Pro (All current updates)
Crystal Fontz 634 USB (using drivers off of crystal fonts webpage)
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Mark

Administrator
I think its an issue with the 634/632 USB drivers.
For some reason occasionally the LCD wont be found and started during windows boot (the LCD doesnt light up).
When this happens, the LCD will need to be unplugged and replugged in before CrystalControl starts (as you have found).

I have a 634 that does the same thing here, and it is quite annoying... CF are trying to find an answer to the problem.
 

ratz34

New member
Umm.. Well the LCD does light up during the time that windows is loading. When it turns on it displays the crystalfontz information.

steps.

1 - turn on pc.
2 - windows loads. (LCD loads up)
3 - the windows user selection is now loaded. (select the user)
4 - all the software loads (even crystalcontrol soft)

thats it. the pc is now on and i'm loged in. With the LCD loaded up. But the COM port that the LCD is on is not accessiable. Here is the exact message I get from crystalcontrol soft.

int of "COM3" failed. The module will be disabled until it is reconfigured.

I get that when i load crystalcontrol soft go to the Configure Module (get it setup) and click Test Settings or just click ok.
 

Temper

New member
I had the same problem and Ill tell you what worked for me. I had an Antec 380 watt Powersupply and I saw the voltages were a little low with Motherboard monitor. I switch out the power supply with a 510 watt and I have not had the problem since. You may want to try that If you are running multiple drives or have a power hungry system.
 

CF Support

Administrator
Chances are, the port that the LCD is on is not the one you think it is on. I would double-check in the device manager. If it *is* on the com port that you think it is, change it to a higher one and change the setting in the software. That should do the trick.
 

ratz34

New member
I've checked. The Com port is COM3. So i changed it to a higher COM port - COM6. Same thing happens.

-Long Shot-
The only system I have gotten this to work on is my brothers AMD XP CPU on an ASUS A7N8X motherboard using the Nvidia N-Force 2 chip set. All the Intel based systems (Mine, my dads, my friends) I have been getting this problem. Just seams strange thats all.


That power supply idea I never would have thought of. I may strip my system down and see if that helps. I wouldn't think that it would since the LCD boots up when windows is loading.
 

JohnAH

New member
Have you by any chance previously run an earlier version of CC and applied an update? I did have version 0.99 installed and updated to 1.02 and encountered exacly the same problem on an XT/2000 based system using an interface that I am designing to provide a USB interface for parallel connected LCD modules. (this module uses a similar 'interface' chip to that on the 632/634 modules and uses the same drivers). After many hours of frustration I decided to remove the drivers from the system using the uninstall provided. I then re-installed the drivers but still had the same problem. I then removed CC using it's uninstall process, again when re-installed I still had the problem. :confused:

I then repeated the driver uninstall and this time also cleared the registry of all entries for the FTDI chip, reinstalled and the problem remained.

Did the same process for CC; uninstalled, cleared the registry of all entries for CrystalControl then re-installed.

Success it all worked!!! :D

So it may work for you (no guarantee) but be sure that you are confident about using Regedit or get someone who is to help you. Please note that when searching for FTDI you will find entries for 'ftdisk' and these must not be removed!!

Good luck.

Johnah
 

ratz34

New member
It's worth a try. But this is a clean install of windows using the new cs software and the lcd drivers.
 
Top