• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Looking for rFactor Plug-in

CF Mark

Administrator
For more info on how the INI files work, look in the "CrystalControl2\documentation\plugin-info" directory.
In there are INI files with comments on what does what.
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

stu3773

New member
Screen scrolling with vista.

I have been trying to get the to work with vista but I have not been able to. I was wondering if any has got this to work with vista. Thanks for any help. Plus one more thing. My usb 634 display is my first lcd display. The display has a vertical refresh that I am not sure is what it is suppose to be doing. I gets worse if you view the display from an acute angle. Thanks again.
 

reider

New member
I have been trying to get the to work with vista but I have not been able to. I was wondering if any has got this to work with vista. Thanks for any help. Plus one more thing. My usb 634 display is my first lcd display. The display has a vertical refresh that I am not sure is what it is suppose to be doing. I gets worse if you view the display from an acute angle. Thanks again.
I have the screen scroll working in Vista for the rFactor setup, nothing working for rFactor itself but I`ll look at that again when I have a chance. Did you mean this rFactor scroll or a general one for any screens you have loaded? If its the rFactor scroll then everything you need is in this thread, I have UAC control turned off in Vista now too, so that may make a difference.

Reider
 

reider

New member
I turned UAC off ages ago, keyboard control works here on Vista. I`ll look at the rFactor stuff again later.

Reider
 

crobol

New member
After one year of my first post in this rF thread I have bought a CFA634. Only 4 days to ship from USA to Europe and the LCD & pluggin works fine.

I can encourage others to buy this material...:D

Thanks at all by your help.
 

Natural1

New member
Hi everyone,
After about 8 months of simply not using the LCD I'm back again, trying to fix the problem. And this continues to drive me nuts.

Here's a recap of the issue...

When in a Race session, pressing "escape" to exit the cockpit and return to the UI causes rFactor to throw an error and shut down. "Escaping" out of the car in any other session works fine - this includes testing, practice, qualify, and warmup sessions.

-There must be something different about the way rFactor exits the cockpit in a race session as opposed to the other session types. The only thing I can think of is the fact that the session effectively "ends" for the player as soon as you hit exit the cockpit in the race session. If AI cars are present they will continue to race, but of course the user no longer has the ability to get back in the cockpit without restarting the session. In all other sessions (those that are not causing problems) pressing "escape" from the cockpit does not end the session for the user. What really surprises me about all this is that, so far, no one else has been able to reproduce the issue.:confused:

Steps to Reproduce
1. From the rFactor main menu, click Control-->Race Weekend. Select any car/track combination.
2. At the track in the practice, qualify, or warmup sessions, verify that you can enter the cockpit and then exit to the garage without error.
3. Advance to the Race session and enter the cockpit. Once on the grid, exit the cockpit. This action produces the error.

Important information...
1. I have continually had this issue starting with the initial rF plugin in December 2007. All subsequent software updates have had no effect. The issue is 100% reproduceable.
2. Since my last post here in May 2008 the following hardware components have been replaced...
  • motherboard, including onboard audio. (nvidia 680 SLI --> Gigabyte solid capacitor board, Intel P35 chipset)
  • RAM (OCZ 1066, original 2x1024 sticks "RMA"d this past summer due to stability issues. Increased from 2GB then to 4GB now. All sicks identical and performing perfectly)
  • Video Card (nvidia 8800GTX --> 280GTX)
  • Power Supply (OCZ 650 watt --> Corsair 750 watt single 12-volt rail)
3. Clean installation of Windows XP Pro following hardware updates, running SP3 now (was SP2 back in May)
3. Working from a completely virgin installation of rFactor. No mods, no tracks, default player configuration.
4. All other applications are performing flawlessly. This computer has NO issues whatsoever in terms of functionality or stability.
5. There is no overclocking being performed and I monitor temperatures frequently.

As you can see, with the amount of hardware being replaced this is basically a new computer. The only common components are the CPU (Intel E6850), case, DVD and hard drive (which has of course been reformatted as part of the upgrade). All drivers are up-to-date.

So, in addition ao the fact that no one else has even seen this problem... I have now reproduced this issue on what is effectively two separate hardware platforms. How does that make sense?

LCD & CC2 installation procedure used...
CC2 Software download: https://forum.crystalfontz.com/forumdisplay.php?f=20
1. Install USB drivers first, following these instructions: http://www.crystalfontz.com/software/crystalcontrol2/manual/lcdsetup.html
2. Plug the unit in
3. Install CrystalControl2 software, following these instructions: http://www.crystalfontz.com/software/crystalcontrol2/manual/install.html
4. Copy “rFactorCC2Plugin.dll” from “C:\Program Files\CrystalControl2\extras\rfactor" to the plugins dir in the rFactor installation (mine is C:\Racing_Sims\rFactor_original_backup\Plugins).
5. Copy “se_rfactor.dll” & “cc2_rfactor.dll” from “rfactor_update” provided in this thread (files dated 5/14/2008) to the root CC2 folder, “C:\Program Files\CrystalControl2”. Backup originals to a separate directory first.

***Please keep in mind that all previous version of the rFactor specific software updates and plugins were tested, and failed to address the issue, prior to May2008***

Recently-attempted troubleshooting tasks...
1. Disabled a number of unnecessary services. Attached screenshot taken just prior to rFactor launch.
2. Shut down all unnecessary applications and processes, including complete uninstallation of AVG anti-virus (was not running in active mode before but I know this would be everyone's first suggestion). Attached screenshots of process list and system tray taken just prior to rFactor launch.
3. Remove all other plugins from the rFactor plugins directory. See attached screenshot.
4. Enabled rFactor trace. See attached text file (rFactor_trace.txt). There appears to be no relevant information here.
5. Tried with and without using the rF "+fullproc" switch for dual core processors.
6. Tried running CC2 as a tray app rather than a service. This does not appear to work properly on XP machines.


Any assistance is highly appreciated.

Thanks!
Scott
 

Attachments

Last edited:

CF Mark

Administrator
I still have not been able to reproduce this error :(

I have a clean version of 1255 just installed, along with the recent release of CC2 (released today) under WinXP.
I followed your steps above, all of which worked without any errors.
I was racing using the keyboard and rFactor in a window (800x600 windowed mode) if that makes any difference.

Not sure what else i can do...
If I can't reproduce the problem here, I cant fix it, sorry :(
 

Natural1

New member
Hi all, I just wanted to chime back in here... After 2 years I dusted off the LCD, downloaded the most recent software and tried again, and I'm happy to report that rFactor is now working properly. I have made no changes to hardware (the exact same PC as before). So I'm guessing that one of the CC2 updates in the past few years must have contained a bug fix that just happened to address this issue.

Thanks :)
 
Top