• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

I just can win with this LCD

mitchjs

New member
Ok, thanks for answering my question about VEE

everything was working, then suddenly the graphics are messed up on the display


the display is a raw lcd display with only segment drivers

the TC6963 is not onboard...

the fonts are drawing correctly , just the screen seems duplicated on top of itself (hard to explain)

I had a extra LCD, so i swapped that in, and that was messed too, so the LCD is good.. its on the main pc board(not attached board to lcd)

anyway... the circuit consisits of some ram and a tc6963
the ram is 8k x 8 sram (HM6264), for $3 i just purchased a new one
so i can drop that in... but if the TC6963 is a issue, where do i buy one?

there is also a microcontroller running this thing, and it has a 32k x 8 and a FONT ROM, again the fonts look fine

i will attach Pics

if anyone has an Idea PLEASE HELP

i really need to save this $1000 piece of gear!
its actually worth so much more, cause u cant get it anymore

mitch
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

Attachments

mitchjs

New member
and now for the good picture

Here is the GOOD

there is no color difference, its just how i took the picture

mitch
 

Attachments

mitchjs

New member
ALL FIXED!!!

it was bad ram!

i replaced the 8k x 8 static ram connected to the t6963c


all is well

mitch
 
Top