• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

HD44780 compatible

Zero55

New member
Hi all,

I'v got a 2x16 HD44780 compatible lc-display (Powertip PC1602-F), connected via the parallel port of my lapop running Win2k and Cystalfontz 1.06 build220. Yesterday i was trying to make it all work and finally it did, but as i started up today to mess around some more, id didn't work at all (just the first row full of black squares).
So i plugged it in to my desktop computer (also Win2k and the same Crystalfonts) and i did get the information i asked on the display, but really messed up.

Does anyone know what the problem may be and what the solution is?

GreetZ
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Tech

Administrator
Pretty much has to be a wiring problem. Do you have ground conductors from the parallel port to the LCD?
 

Zero55

New member
i don't think so, i cut off the wires i didn't needed at the other end of the cable. So only 10 wires are connected between the parallel port and the lcd
 

Zero55

New member
can you be more specific please ?
Do i need to connect the shield of the parallel port or something else to the ground of the display?

thanx
 

CF Tech

Administrator
The PC's parallel port has a bunch of "ground" pins. Use a 25 conductor cable (just start with an old printer cable), bring all 25 conductors to the LCD. Connect all the ground conductors together at the LCD, and tie them to the ground pin of the LCD.

It is a little bit like an 80 conductor IDE cable, the 40 extra conductors are all grounds (and also 20 of the original conductors in a 40-pin IDE cable, IIRC).
 
Top