• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CPU, HDD, Temps and Voltage are not displayed

daks001

New member
jffcurt said:
P.S. Just numbers, big numbers

Jeff
Beacause character LCD screens are limited to 8 custom characters I can only give you the data in Big Numbers and not the Drive letter too....

Anyways just substitute the drive letters that you want and this one will display one drive per screen and you can copy it 4 times and have it scroll through them... OR

opt02="full_name=\LogicalDisk(C:)\% Free Space" <obviously you'll be changing this line for whatever drive letter you want.


edit this part of the screen like below for each different screen so the Big characters are in different parts of the screen for each drive and that way you'll always know which one it is...



[r00-i00]
length=15 < #a Change to 2
options=0
string="HD C: % Free" < Change to "C:" or whatever as we'll need the space

[r00-i01]
id=@02

[r01]
options=0

[r01-i00]
length=15 < #b Change to 2
options=0
string=" "

[r01-i01]
id=@03

[r01-i02]
string="%"

Now for the second screen Change #a and #b to 5, for the third to 10 and in this case the forth is 15.
 

Attachments

jffcurt

New member
Believe it or not I just cut and pasted my way to my first screen and it works. "Diskspace Big Num". Of course I cheated off of CPU Big nums, but that's what I need from the distance I set at........Now if I can just keep it up. Jeff
 

daks001

New member
jffcurt said:
Believe it or not I just cut and pasted my way to my first screen and it works. "Diskspace Big Num". Of course I cheated off of CPU Big nums, but that's what I need from the distance I set at........Now if I can just keep it up. Jeff
If copy and paste is cheating then 80% of my screens are cheats!:D

The sample above is also from the same cheat! LOL

BTW you *should* not have to reboot your computer after each screen change just restart CC2...

Once you get the hang of these screen "scripts" they are pretty easy and logical, I just forget to renumber some things after I've pasted them.

;)
 

jffcurt

New member
You had a great idea spacing differently on each screen. Basically though we were just about the same. The one problem I have been noticing and I've seen a couple of posts about it today is Crystal Control is having a problem shutting down the cc2_services. The last couple of times i've had to go into administrative services and shutdown the service so I wouldn't have to reboot again. I wonder if I might have to many screens loaded.............
 

daks001

New member
jffcurt said:
You had a great idea spacing differently on each screen. Basically though we were just about the same. The one problem I have been noticing and I've seen a couple of posts about it today is Crystal Control is having a problem shutting down the cc2_services. The last couple of times i've had to go into administrative services and shutdown the service so I wouldn't have to reboot again. I wonder if I might have to many screens loaded.............
Try removing your e-mail screen(s) and deleting the cc2_email.ini file from your service directory and see if that helps. (you'll have to do the manual service re-start one more time though).
 

jffcurt

New member
Emails are gone. I stopped using it anyways. Let's see if that helps. Thanks.

How would I add a degree sign "o" to a bug num??????
 

reider

New member
jffcurt said:
Emails are gone. I stopped using it anyways. Let's see if that helps. Thanks.

How would I add a degree sign "o" to a bug num??????
Its ok, I`d partially fixed that but gave up around 4.30am. Will complete it now and let you know when its fixed.

EDIT:
Now done and ready to download

Steve
 
Last edited:

reider

New member
jffcurt said:
Are you saying you modified the screens you posted a little earlier??
Thats right, added the degree sign to all the 631 module and just uploading the 634 module now.

Steve
 

sandman

New member
erhhh...

is there a chance to get a version which installes and works "out of the box" in the near future?!?
 

jc634

Administrator
sandman said:
erhhh...

is there a chance to get a version which installes and works "out of the box" in the near future?!?
Probably when the screen editor is released. Even for us BETA testers, there is a learning curve to a very powerful program!

As we learn and discuss our findings, we modify our screen code to add more/better features!:D

Jim
 

reider

New member
But even 'out of the box' this still leaves those who need extra customisation. Therefore we will still be editing screens to suit people.

Steve
 

sandman

New member
reider said:
But even 'out of the box' this still leaves those who need extra customisation. Therefore we will still be editing screens to suit people.

Steve
thats nice... :)
i am looking forward to see the "final" version of this fine piece of software :)
 

JJ001

New member
Hi!

I'm from Austria - running a german WinXP SP 2 - and updated my old CC Software to CC2...

Do you have any ideas how to change the the cc2_perfmon.ini and the CPU Usage Big Nums.2004 that the CPU activity is displayed!?

I've played around a while with the perfmon_enum.exe in order to change the *.ini File and the big nums screen but it still doesn't work...

Hmmm - does anyone have any idea!?

That's my cc2_perfmon.ini --> already changed into German

[perf00]
id=3918556105
full_name="\Prozessor(_Total)\Benutzerzeit (%)"
precision=0
multiplier=1

[perf01]
id=942311070
full_name="\Prozessor(_Total)\Benutzerzeit (%)"
precision=0
multiplier=1

[perf02]
id=3294140396
full_name="\Prozessor(_Total)\Benutzerzeit (%)"
precision=0
multiplier=1

[perf03]
id=115803149
full_name="\PhysicalDisk(_Total)\% Disk Time"
precision=0
multiplier=1


and that's my screen file:

sec="perf#"
opt01="id=@01"
opt02="full_name=\Prozessor(_Total)\Benutzerzeit (%)"
opt03="precision=0"
opt04="multiplier=1"

[from01]
from="cc2_bigchars.ini"
sec="big-#"
opt01="id_item=@01"
opt02="id1=@02"
opt03="id0=@03"

... and so on


Thanks in advance!

JJ
 

jc634

Administrator
JJ001,

Welcome to the forums!

I am not sure how the translation to German works, but comparing your line to my English line below:

full_name="\Processor(_Total)\% Processor Time"

full_name="\Prozessor(_Total)\Benutzerzeit (%)"

It *seems* that your line should read:

full_name="\Prozessor(_Total)\% Benutzerzeit"

Just a guess at this point.

Jim
 

JJ001

New member
Hi Jim! Thanks for your fast reply!

You gave me an important hint - it was the wrong line in my perfdump.txt!!!

Of course it's the "Processor Time" which I need (it's already too late here in Austria *gg*).

My CPU Usage now works perfectly fine! I'll fix the rest (HDD) in a couple of minutes so that the bars and bignums will work for german XPs.

cu

JJ

Ok - everything is fixed now! Due to the fact that I can't attach any files in the forums, I post the content of the fixed (German) cc2_perfmon.ini -> just copy, paste and save it:

[perf00]
id=3918556105
full_name="\Prozessor(_Total)\Prozessorzeit (%)"
precision=0
multiplier=1

[perf01]
id=942311070
full_name="\Prozessor(_Total)\Prozessorzeit (%)"
precision=0
multiplier=1

[perf02]
id=3294140396
full_name="\Prozessor(_Total)\Prozessorzeit (%)"
precision=0
multiplier=1

[perf03]
id=115803149
full_name="\Physikalischer Datenträger(_Total)\Zeit (%)"
precision=0
multiplier=1

I've also fixed two screens - maybe an admin gives me the right to attach these files!

gn8

JJ
 
Last edited:
Top