• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CFA-633 Linux serial test software

brainproxy

New member
Hi!

I have opened a trouble ticket, but wanted to throw this out there to any linux guys who may be able to help me. I am fairly new to Linux, but I have a pretty good grasp. Here is the situation:

I can execute test 633:

brainbox root # /usr/local/crystalfontz/631_633_linux/test633 /dev/ttyS1 115200
Ultra-simple CFA-631 / CFA-633 / CFA-635 command-line communications example.
Crystalfontz America, Inc. http://www.crystalfontz.com

Usage:
/usr/local/crystalfontz/631_633_ linux/test633 PORT BAUD
PORT is something like "/dev/ttyS0" or "/dev/usb/ttyUSB0"
BAUD is 19200 or 115200
To clear the display, enter "clear" as an optional third parameter

Serial_Init:: tcgetattr() failed
Could not open port "/dev/ttyS1" at "115200" baud.

###

It is as if there is nothing connected to the serial port. I have tried this with ttyS0 - 7 just to be sure. Also with 19200 baud.

I have the CFA-633 serial connected with a 9 wire RS232 plug to my PC as well as the floppy power cable from my power supply. I recieve no life-signs from the LCD at all. Is this normal?

The cable I scavenged from a serial replicator port. I used a gender changer and plugged this into the PC so I could connect the cable.

I aligned the red wire to the "top" of the LCD so that pin 1 would correspond to wire 1.

The /dev/ folder holds ttyS0 and ttyS1, so I assume that they are valid devices.

I hope this information helps.

Thank you in advance,

Will
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

CF Tech

Administrator
Opening an RS-232 (Com) the port is possible with or without a device connected to it, so it is expected that you get the same error with or without the CFA-633 connected.

I am not sure why the open call is failing. My first guess would be that port names like /dev/ttyS0 are not correct for your system, though I would not know how to verify that guess. I'll ask CF Web to look at it, they have more Linux experience.
 
Top