• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Asus k8n-dre and a 633 lcd

scorder

New member
Asus K8N-Dre and CFA633 issues

Has anyone had any luck getting a 633 working on an Asus K8N-DRE? I am unable to flash the LCD. I have tested it on two different DRE boards and w/ two LCDs. All serial support is on in the bios and the serial ports are functioning. I have even called Asus to make sure that there wasn't anything funny about the serial connector...which there is not. Tested with RedHat Ent 4 and Suse 9.3. Any ideas would be appreciated.

Thanks
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

scorder

New member
Ran the test and got this output. I also tested this with the cable flipped upside down with the same results.

linux:/home/633_linux # ./test633 /dev/ttyS1 19200
Ultra-simple CFA-631 / CFA-633 / CFA-635 command-line communications example.
Crystalfontz America, Inc. http://www.crystalfontz.com

Usage:
./test633 PORT BAUD
PORT is something like "/dev/ttyS0" or "/dev/usb/ttyUSB0"
BAUD is 19200 or 115200
To clear the display, enter "clear" as an optional third parameter

Serial_Init:: success
"/dev/ttyS1" opened at "19200" baud.

Timed out waiting for a response.
Timed out waiting for a response.

Ctrl-C to exit.
Updated display, now waiting for packets
 

scorder

New member
Has anyone had any luck getting a 633 working on an Asus K8N-DRE? I am unable to flash the LCD. I have tested it on two different DRE boards and w/ two LCDs. All serial support is on in the bios and the serial ports are functioning. I have even called Asus to make sure that there wasn't anything funny about the serial connector...which there is not. Tested with RedHat Ent 4 and Suse 9.3. Any ideas would be appreciated.

Thanks
 

CF Tech

Administrator
What cable are you using?

Have you checked the pin-out? It may be that the module needs to be set to "alternate".
 
Top