• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

16x2 LCD problem - NEWBIE!

pingo

New member
Hi all!

I'm a newbie at LCD-displays, so please don't flame me. :)

Anyway, I just bought a 16x2 LCD display with two Samsung
KS0076-chips on it. According to the LCD-creator (Data International), the KS0076-chip is exactly "the same" as the HD44780-chip.

Anyway, I made some cables today, and I have double-checked them - they are fine. And yes, I've double checked them. The cables are fine. I repeate: They are fine.

The problem is though, that when I power this little thing on, the first 16 chars (the first row) lits up (it is LED-backlight, did I say that?). The second row is blank/black. (I hard-wired pin 3 to ground, so the first rows backlight is REALLY BRIGHT too.)

The person I bought it from says that this is normal and that the display might need to be initialized.

My questions are...

How do I go from this to a fully working display which I can use with, say, the WinAmp plugin?

My second question is... ah, well, no, my first question is enough, really.

And yes, I did double check the wiring, by the way.

Yours,
Pingo
Sweden
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Tech

Administrator
First off, check your wiring :D

Give CFAH_WinTest a try. Once that works, you can use CrystalControl (unsupported though, since it is not a CF LCD).

Your backlight will need a backlight dropping resistor.
 

pingo

New member
Init is the problem ... but HOW to do THAT?

Hi again,

Well... I got an answer again from Data International, and they say that this unit needs to be initialized software-wise according to page 28 in this PDF:
http://www.allshore.com/pdf/s6a0069.pdf

And yes, that is for the Samsung S6A0069-chip, which is the replacement IC for the Samsung chip used in my display.

Apperently, both the seller and the guy at DI says that the LCD-display is functioning correctly. And I have checked my cables AGAIN.

So, obviously, this is the problem.

HOWEVER, I tried to initialize the LCD using CFAH_WinTest but nothing happens. Apperently the init in CFAH-program is not the same as this display needs.

Anyone know what I should do to init this display so I actually can USE it??

Thanks for any help...

Yours
Pingo
 

CF Tech

Administrator
The initialization for all these displays is generally based on the "HD44780" (the "original" character controller).

So it probably comes down to < . . . heavy sigh . . . > check the wiring.

If you use the little push buttons on CFAH_WinTest, you can toggle each individual line. Look at them with a DMM and make sure the right pins are moving at the display.
 

pingo

New member
Still probs...

Hi again,

Thanks for trying to help!

Though, I just checked the wires - again - using a DMM, much like the one you posted a link to at Radio Shack. I had to use this DMM when I made the wire too, since I only had a wire with 24 leads, and only 7 colors :)

So, I have now checked my wire FIVE times with the DMM. In different rooms, in different ways, and all led to the same results: The printer port connection is made exactly as it should, when checking on the display pin's itself.

I still get the same phenomenon.

According to the guy at Data International, the init sequence is special fot the S6A0069 (or KS0076 that's on my unit). Though, I don't know this and I have no way to check that. If someone wants to control page 28 on the PDF I sent a link to above, and see if it is the same sequence (as in an init to a "real" 44780) or not, I would be very happy. :)

As an update, I can say that it is an 16x2 display and the top row is lit but the 2'nd row is dark - and that's all I get out of it. I've tried several software's, WinAmp Plugin, Smartie 5.1, jaLCDs, CFAH_WinTest ... none of them made any difference.

Is it possible that the printer port is faulty?
Is it possible that the LCD display is corrupt?
Is it possible that the wire IS corrupt, even though the pin outs are correct? (Weird question...)

Anyway ... I have no idea. I'm lost. :-/

Yours
Pingo
 

CF Tech

Administrator
If you can test the signal all the way from manually toggling the line in CFAH_WinTest to the correct pin on the LCD (put the DMM on volts, and make sure it measures close to 0 for low, and above 4v for high at the LCD) then your cable by definition is OK.

If the KS0076 init really is incompatible with the "industry standard" then you will have to talk some software author into supporting that init sequence. If you or a buddy has access to MSVC, then you can test out a new init sequence in CFAH_WinTest by modifying the source.

In theory you could initialize any display by using the toggles on CFAH_WinTest, but you would probably get really tired of clicking.
 

spock

New member
problem

If I might offer some insight, you have to be sure the wiring is as it should. Many people have the wiring checked, but haven't given some thought to the orientation of the parallel port plug. So, make sure you have the right pins connected in the parallel port plug, the DB-25, and you have paid attention to the numbering of the plug. If you look closely enough, you will see some tiny numbers on the plastic around the pins of the plug. Make sure these numbers are the right ones, cross-checking them with the schematic you used.
By the way, the black characters on the first row and blank on the second are correct; that's the way all HD44780 and compatibles initialise. That means your controller is alive.
Success!
 

CF Support

Administrator
The blacked out characters on the front row indicate one thing, and only one thing:
The controller's not dead.

You can get those characters by throwing away your parallel cable, connecting power, ground, and Vo (~+1v from a 10k pot)
 

spock

New member
?

Isn't that what I just said? Black row is the internal initialization pattern of the controller! If it's there, the controller is alive!
 
Top