• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

XES635BK Problems - Blank Screen

jantman

New member
Hi,

My XES635BKTMFKU just arrived today. It just so happens that my boss was out of work, so no-go on our big project for the day. I ran home, picked up the package, and by 5:00, had it working on my workstation (OpenSuSE Linux 10.3) with the Linux test program. I also wrote up a Python class using PySerial to control it, and confirmed that it worked.

Once I got home, I plugged it in to the machine I intend to use it with - an older HP OmniBook laptop with one USB 1.1 port, running Debian Linux (4.0). I had it plugged in through a hub, as there was already a USB Dallas 1-wire adapter. Once I plugged it in, it wouldn't work - I got a backlight, though dimmer than it should be. No text on the screen, and all LEDs lit - some green, some orange, some red.

I ran out to buy a powered USB hub, but it didn't make any difference at all.

I tried my Python class with no luck. I also tried the test program, but all I got was:
Code:
Serial_Init:: success
"/dev/ttyUSB1" opened at "115200" baud.

Timed out waiting for a response.
Timed out waiting for a response.
Timed out waiting for a response.
Timed out waiting for a response.

Ctrl-C to exit.
Updated display, now waiting for packets
I gave interceptty a run to verify the data, and it appears that the correct data is going out, but *nothing* is coming back from the LCD.

It seems to be correctly recognized by the OS as /dev/ttyUSB0 (/dev/ttyUSB1 is the pseudo-device created by interceptty):
Code:
usb 1-1.2: new full speed USB device using uhci_hcd and address 21
usb 1-1.2: configuration #1 chosen from 1 choice
ftdi_sio 1-1.2:1.0: FTDI USB Serial Device converter detected
drivers/usb/serial/ftdi_sio.c: Detected FT8U232AM
usb 1-1.2: FTDI USB Serial Device converter now attached to ttyUSB0
I was really psyched about this - and this laptop is pretty much the only device I have that meets the specs of my project. I really would hate to have to return it and use an older serial LCD.

Thanks in advance for any help,
Jason Antman
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

jantman

New member
Seems like this may be something like the problem described with a CFA-635 here. I assume they're both close, if not the same, on the inside?

I don't remember seeing anything in the manuals about the Jumper... and this is the only Debian system I have, so I really have no way of testing whether it's hardware or software (well, I could try a Ubuntu liveCD, but that's Debian-based, so I don't know if it would help...)
 

CF Tech

Administrator
Can you scare up a windows machine to give it a shot on? It would have been tested here before it went out.

It is just a regular CFA-635 inside a metal case.

JP2 should be closed by default. I guess if it was open that could cause trouble like this, but it would be a strange failure to work on the first machine and not the second. If you take it back to the first machine, does it still work OK there?

Please let me know what you find.
 

jantman

New member
As I said, I tried it on my HP workstation at work, and it operated perfectly. I was able to change the text, LEDs, backlight, etc. through the Python class I wrote. The problem, at the moment, is only occurring with this one older (probably a Pentium I) laptop - regardless of whether there is a powered USB hub in place or not.

I've also tried it again plugged into the USB port on my Asus eeePC, and it works fine there, too (after the problems with the old laptop).

I don't know much about either USB (on a technical, hardware/electronics level), but I have 2 theories at this point:
1) Faulty FTDI driver in Debian 4.0.
2) The laptop isn't putting out enough current through the one USB port to power the LCD. But I'd think that a powered hub should fix that.

Some sort of power issue seems like the most likely cause to me, but I thought that when it comes to power, USB is USB is USB - unless HP didn't follow some spec when they built this laptop.

Thanks for any help.
If I don't get this worked out by Monday or Tuesday I may be forced to RMA this...

Now, in the event that I do return it... do you guys offer the CFA-635 (serial) in an enclosure like the XES? Or, is there a way that I can convert my XES635 to a serial CFA-635? (I don't know how different they are - if it's something I can easily reverse, like a plug-in adapter board, then I'd give it a shot. Not if it will void my warranty).
 

CF Tech

Administrator
I really do not know what could be going on. It could be that the P1 laptop USB hardware is not up to spec. I think if the Debian FTDI USB was bad there would be a lot of people looking into it (we are only one of many people using the FTDI part). Do other USB devices work OK on that platform?

The 635XES cannot be made serial. The serial version uses an extra little converter board that will not fit into the slim 635XES case.

I guess if you can't get it to work, we will accept a return on the module.
 

jantman

New member
Thanks for the advice.

I have a USB webcam (tiny little $20 module), Dallas 1-wire USB adapter, and a Phidgets InterfaceKit 0/0/4 all running off of the hub with no problems.

I have a spare box at work, on Tuesday I'll put an identical install of Debian on it just to rule out some subtle software glitch (though I'm using stable, so that shouldn't be the case). Assuming that works as expected, I'll start looking around for another machine to use for the project - or maybe bite the bullet and buy a Mini-ATX board and case.

I *love* the display, at this point, I'll switch out the box before the display...

Thanks for all the help. I'll update when I have news.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

jantman

New member
Well, I can't sat exactly what it was (sorry, guys). Another part of the project ran into issues with Debian, so I just grabbed a spare desktop and put CentOS 5 on it. Works like a charm.

Thanks.
 
Top