• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Weird ATX-Controls

Guinness

New member
Hi i have a CFA-635 Display with a SCAB Board connected. I want to use it for a Linux box as ATX controls.

I have connected all cables, have opened JP2 on the CFA-635 as well as JP8 on the SCAB. JP9 on the SCAB is closed.

I have programmed the the GPIO Pins as ATX controls and set the ATX controls with command 28 and saved all as boot state.

The problem is i can reset the box with the CFA and power off as well. But once i have power off the Display is on and shows power off, even the box is off and everything is off. I can't power on as well because it always shows Power off on the display.
The real crazy thing is if i press the power off button on the LCD for 4 seconds again the box powers on?!

I'm stuck and need help :)

Thanks...
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

CF Support

Administrator
You may need to experiment with the other possible settings for the ATX command, i.e. \244, \246 (depending on the directions the pins need to be pulled).

Did you use \240 as the command option, or some other bit mask?
 

Guinness

New member
Hi,

yes i have used the \240 bit mask. I have also tried \244 \246 \242 but then nothing works.

It has worked already with that bit mask, but my collegue has tried some new options and now it doesn't work anymore, although i use the same commands and procedure like the first time.

I don't know exactly what he did. Is there a command to reset the whole LCD?


Thanks
 
Top