• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

USB 632 usage problems

gligon

New member
I've got the drivers downloaded. I plug in the unit and it detects it and I've got it successfully installed. I've downloaded and installed CrystalControl. I've setup a screen just something basic, time/date to get a feel for what I'm doing. I'm getting nothing on the LCD. Not a light, not a thing. Am I doing something wrong?
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

jc634

Administrator
Couple of things:

1. CrystalControl1 or CrystalControl2?
2. Download and run Wintest to check hardware/drivers. http://www.crystalfontz.com/software/wintest/index.html. Stop CrystalControl before running Wintest.
3. Assumming that Wintest works, and you are running CC2, you might want to zip up the log files from the CC2 directory so that someone here can peruse them to see what might be wrong. Complete instructions on what to do to report a problem is here: https://forum.crystalfontz.com/showthread.php?t=4418.

Hope this helps...

JC
 

Crystalmancer

New member
Also, make sure you chose the correct COM port in CC2.

I always make that dumb mistake when I install new versions of CC, because it defaults to COM port 1, but my LCD is on COM port 3. Of course, like you I get nothing, until I go back and pick the right port. :p

Good luck.
 

gligon

New member
Wintest was unsuccessful. I am using the proper COM port and whatnot. I downloaded and installed CC2 and it sees my unit but I still get nothing on the display. I'll try this on another computer and see if that makes any difference.

If this unit is broken, and I bought it more than 30 days ago, I'm SOL aren't I?
 

gligon

New member
I just tried it on a different computer and it's still not working. It's installing and being recognized by the software but nothing is displaying. I've even tried messing with the two dipswitches on the back as it's not completely clear as to which position they should be in, with no positive results.
 
Top