• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Slightly Corrupted Screens

jc634

Administrator
CC Admin,

Occasionly, my 631 does some weird screen displays. Namely,

1. On Bargraphs, line should look like:

¨€¨€¨€¨€¨€¨€¨€¨€∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙
¨€¨€¨€¨€¨€¨€¨€¨€∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙

and it actually looks like:

¨€∙
¨€∙

2. Part of the GIF from my showgif_16amfl.2002 screen occasionly bleeds thru my jc_CPU Usage Big Nums.2002 screen (just to the left of usage number).

I have noticed it happening once in a while as it scrolls thru screens. I can also get it do it more often if I use the buttons to scroll quickly thru the screens.

It is not a real big deal. Just thought I should mention it, though. Perhaps a buffer is not clearing out between screens? Or perhaps character generation between my 634 and 631 causing some problem?

Jim
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

jc634

Administrator
Yech!

Bad graphics generation!:(

Hope you understand what the translated graphics represent

Jim
 

reider

New member
jc634 said:
CC Admin,

Occasionly, my 631 does some weird screen displays. Namely,

1. On Bargraphs, line should look like:

¨€¨€¨€¨€¨€¨€¨€¨€∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙
¨€¨€¨€¨€¨€¨€¨€¨€∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙∙

and it actually looks like:

¨€∙
¨€∙

2. Part of the GIF from my showgif_16amfl.2002 screen occasionly bleeds thru my jc_CPU Usage Big Nums.2002 screen (just to the left of usage number).

I have noticed it happening once in a while as it scrolls thru screens. I can also get it do it more often if I use the buttons to scroll quickly thru the screens.

It is not a real big deal. Just thought I should mention it, though. Perhaps a buffer is not clearing out between screens? Or perhaps character generation between my 634 and 631 causing some problem?

Jim
Mine does the same but I`ve noticed its only when the 631 screen does the automatic `screen refresh` every so often. A quick up then down on the buttons and its back to normal for me. Don`t know if you`re getting it the same way as this, but try the buttons if you haven`t already.

Steve
 

jc634

Administrator
The 1st time I scroll thru the screen using the buttons, it seems that I can generate the corruption. If I do it more, it seems to work fine.:confused:

That is about the only pattern I can discern. If there was some other pattern I could discern, I would try and document here.

Jim
 

reider

New member
jc634 said:
The 1st time I scroll thru the screen using the buttons, it seems that I can generate the corruption. If I do it more, it seems to work fine.:confused:

That is about the only pattern I can discern. If there was some other pattern I could discern, I would try and document here.

Jim
My screen looks ok, regardless of the button press or non button press. Sit and watch the screen for a few moments and at some point it will refresh on its own sometimes causing the corruption. It is at this point I use the buttons to go one position up then back down. This clears the screen corruption.

If on the other hand, as sometimes happens, the screen goes to the boot screen then their is no corruption at all (I can understand the lack of corruption here). Accessing the buttons moves the panel back to the screen it was originally on. Its no great problem, just a bit irksome at times. One thing I do though is make sure their are no blank screens in the scroll.

Steve
 

CF Mark

Administrator
This is caused by a 631/633 packet handling bug i havnt been able to fix as yet :(

Now and then it causes a line update, or character update to be dropped meaning you get the problems mentioned above.

Ill keep trying to find a fix...
 

jc634

Administrator
CrystalControl Admin said:
This is caused by a 631/633 packet handling bug i havnt been able to fix as yet :(

Now and then it causes a line update, or character update to be dropped meaning you get the problems mentioned above.

Ill keep trying to find a fix...
That's OK. I just wanted to make sure you were aware of it:)

Jim
 
Top