• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Problems with hd44780 and CC1/CC2, strange garbled text.

CraXyOW3

New member
So, i had this display ages ago and i worked lovely and just recently i plugged it in again.
Been trying to figure out what was wrong with it , showing "SWAP" text as "S_IAL" or similar.
Downloaded CFAH_Wintest and when i try "init 8bit" the display shows the text "* Crystalfontz *" as "WO*Cr}svcnfonvz".
When i press "init 4-bit" it works perfect. Been searching and trying to find how i can set CC1 to 4 bit, no results so i guess im swimming in the blue.

Downloaded CC2 and it looked lovely and all, but everytime i try to add a label, the software hangz and complainz about "ntdll.dll"

Anyone who can help me ??
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CraXyOW3

New member
update

Crash info:

Occasion 1

AppName: cc2_config.exe
AppVer: 2008.4.2.977
ModName: cc2_config.exe
ModVer: 2008.4.2.977
Offset: 00036e80

Occasion 2

AppName: cc2_config.exe
AppVer: 2008.4.2.977
ModName: ntdll.dll
ModVer: 5.1.2600.5512
Offset: 00010cae


Occasion 2 repeats itself afterwards, don't know what im doing wrong .....
 
... when i try "init 8bit" the display shows the text "* Crystalfontz *" as "WO*Cr}svcnfonvz".
When i press "init 4-bit" it works perfect.
The only difference is that 8-bit mode uses data bits 0-3 as well as 4-7, so maybe you have a wire that has broken loose or shorted to another bit.
 

CraXyOW3

New member
I went over all the cables and did found one cable that had a clean cut where it was once solded, so i didn't notice it.
Saw it now and corrected it, now i got another problem -.-

CC2 still crashes and CC1 would not let me use "bounce" and "Scroll" wich it once did.
The checkboxes are there and i can tick them but no change on display at all.
 
Top