• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Problems displaying specific characters through CC2

hgcx811

New member
Hi, I just bought a 634 display. I have no experience with programming an external LCD-display so far. I read this forum for the last 4 or 5 days, trying to find a solution to my problem but so far nothing worked.

I have a project in which I have to read back postal address data from a text file which is created by Microsoft Access. It is a simple text file which updates through the use of Access and I worked with the text file reader in CC2. Everything worked out so far. The display shows the created txt and updates itself in the set time.

Now I have got a problem with specific characters. I am from Germany and I have to display the following charaters: Ä Ö Ü ä ö ü ß

I created the screen and used regex .* at first and I get a result in CC2 where just those characters are missing. For example the unfiltered text looks like:
Mühlstraße 99
99999 Südstadt

If I apply regex .* in the Results window it returns:

M hlstra e 99
99999 S dstadt

So I get only this result. I also tried to look only for the special characters I need with regex (.*)[ÄÖÜäöüß] and it gave me back a blank result in the Results window. So it must recognize the characters but doesn't print them on the screen or on the display, otherwise I would get a failure message. Am I using the wrong regex or is it a problem of CC2? :confused:

If I could get at least some characters/ symbols to show in CC2/ on the display, I would be able to work with cmap and substitute them with the correct ones. But it doesn't work with whitespaces... I hope somebody could help me with my problem.
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
Top