• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

OLED Display not powering on .

uppiliprasadh.V

New member
Hi,
We are using CFAL12864G-024W 128x64 2.4 Inch White OLED in our design.
we had given 13 Volts for display and 3.3 Volts for Logic. In addition the Reset line is tied to ground.
There is no activity on the display. Attached is the connector Schematic. The BS1 and BS2 lines are tied to ground to enable SPI configuration.
Request you to give your suggestions.



Crystalfontz Connector Schematic.PNG

Regards,
Uppili Prasadh.V
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Kelsey

Administrator
Staff member
Reset should be toggled when the chip is initialized and then pulled high during normal operation.

The datasheet for this part is available here: https://www.crystalfontz.com/products/document/3707/CFAL12864G024Wv1.1.pdf

and the description of the reset chip is on page 5:
"Reset signal input.
When RES# is pulled LOW, initialization of the chip is executed.
Keep this pin pulled HIGH during normal operation"

It looks like there are a few other issues with your schematic. For instance, pin 29 should have a cap to ground, and pin 28 should have a resistor to ground.
 

uppiliprasadh.V

New member
Hi ,
We are trying the configuration through SPI. For the VCOMH pin we have provided a decap to ground.
For pin no 28,Iref we have connected to ground through a resistor.
We will revert back with the results of the testing with the updated resistor and capacitor values as per the attached datasheet.


Regards,
Uppili Prasadh.V
 
Last edited:
Top