• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

no go with CFAH2004ATMIJP

poor user

New member
Hello!

I have a 20x4 white on blue CF display.
i wanted to hook it up the parallel port of my computer.
i wired it according the 'standard' wireing-plan found on nearly every modding-page on the net.

but when powering the display nothing happens, no 2 solid lines and nothing when jalcds has begun running.

i checked the wireing about 12 times, used a multimeter to be a 99,99% sure and i can assure you: i did everything correct.

what do you think? may the controller unit or what ever it is may be damaged or something like that? the white backlight works perfectly.

i am really desperate as CF displays are not the cheapest :(
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Support

Administrator
First, the disclaimer:

We do not recommend the parallel modules (such as the one you are interested in) for end-user PC applications. These modules require more extensive wiring knowledge and the proper tools. These modules are primarily intended for OEM (manufacturer) use, and as such, we do not carry any cables, brackets, or serial adapters for these modules.

We do not offer end-user tech support on the CFAH* series LCDs in PC applications. We will not accept returns on CFAH* LCDs damaged in an attempt to connect them to a PC.

That aside, you can get that first line (or 1st and 3rd lines) of characters to be in the full-on condition merely by getting 5v to pin 2, ground to pin 1, and 1v to pin 3 (through a 10k pot).

If you see the lines, that means that the controller is awake and alive.

However, you may want to check the data lines and control lines, as that's likely where your problem lies. If you're 99.99% sure, check again with a program like CFAH_Wintest (http://www.crystalfontz.com/software/CFAH_WinTest/CFAH_WinTest_Source.zip) to pull the lines high and low to verify they're correct. If you've soldered and unsoldered pins, make sure that you haven't lifted any traces or pads off the board, as you may think that you're in the correct place on the PCB but not making any electrical contact.

Good wiring guides for HD44780 compatible LCD's can be found:

http://www.myrolypoly.com/lcd_project/lcd_project.html

http://www.icehw.net/article.asp?id=104

http://www.geocities.com/ResearchTriangle/1495/ee_lcd.html

http://www.overclockers.com.au/techstuff/a_diy_lcd/

http://www.hardforum.com/showthread.php?threadid=248302

You can also go to http://forums.bit-tech.net/showthread.php?threadid=5582 and search for "assuming alphanumeric" and you will find a short Q/A post on parallel displays.

My guess is that it's merely a wiring problem and you're probably closer than you think.
 

poor user

New member
i solved my problem.

i checked the wireing of the cables... but not of the 10k poti *doh!*

stupid me, soldered the poti the wrong way round , changed it and now it works, ****, i am really ashamed of me now :rolleyes:
 
Top