LCD shuts off for no reason


New member
CrystalControl Admin said:
If you hover your mouse above the blue icon itll say how many LCD updates there has been.

Can you check this again a few seconds later and see if the number of updates has changed?
Yep it is updating and the number is rising and it is off again...
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.


New member
Ok, I have some interesting info to add to this. Ive been experimenting.

When the display is off/failing, I can get it to come back on by using the taskbar icons brightness slider. Move it up or down, and the display lights back up, but no chacters are displayed until I move the contrast slider, then they show back up. At this point the display is back on, but the readouts are corrupted. Specifically, the degree symbol is now a solid square in the lower portion of that chacter cell, and one single pixel in the top half of the same cell. The numbers for the temp readout are displayed normally. The text labels, like Case and CPU, are displayed normally..

I tried to take some pics of the display, but it the readout wouldnt show up in the pictures.


New member
Update on the new drivers.. well I left my comp on all last night to try the new drivers and the update is that it still stops running , but now in a different way.

When I left it running last night it was fine cycling through the 3 or so screens I have... Now it is stuck at the Default Crystalfontz startup screen that shows HW version and FW version... but nothing changes..

also the CC2 tray icon is still blue and I hovered over it a couple of times and it still shows it is updating and the updates are going up...



I tried:(

I guess I will have to step aside and CC admin try and figure it out.

I am sorry it did not work.



New member
Lcd cut off last night as well, the display backlight stays on but it's a blank screen, and CC2 is still updating the display as shown in the taskbar.


New member
Same problem still happening... Is the end result of this just going to have to revert back to CC1, since no more tech support or assistance in trying to fix this situation? As it appears this is not a one person problem.


New member
Batdive said:
Same problem still happening... Is the end result of this just going to have to revert back to CC1, since no more tech support or assistance in trying to fix this situation? As it appears this is not a one person problem.
This is a bit of a longshot but I had something like this happen when there was corruption in one of my .ini files.

Stop CC2

Go into your C:\Program Files\CrystalControl2\cc2-service (or whatever drive letter) and delete all .ini and .log files. Double check to make sure all the .ini files are deleted.

Fire up CC2 config and re-install your display to the correct com port and add the screens you want.

Re-start CC2... fingers now crossed and breath held.


New member
daks001 said:
This is a bit of a longshot but I had something like this happen when there was corruption in one of my .ini files.
Well thanks for the attempt atleast.. But I did try it and to no avail, it did not work.. Same problem as before. Runs for awhile then shuts off or goes back to the boot screen.

Kind of sad for a company that the best tech support or at least attempts to fix the problem have come from end users and beta testers.. No more recommending Crystalfontz to my friends...

CF Tech

29 posts on the issue and you are upset? What else would you have us do?

There is nothing wrong with the hardware, right?

We do not write the USB driver, so we are not in a position to change it. If you think it is the driver, the best I can suggest is to contact and ask them to look into it.

I'll see if we can whip up a windows command line test utility that just hammers on the display. That would remove CC from the mix and leave only the driver as suspect.

If it is for sure CC2 then we will make sure CC Admin has exhausted all the possibilities trying to debug it.

Also, you can always escalate an issue out of the forum into a ticket by writing support(at)crystalfontz(dot)com, although that would only help if it is a hardware or driver issue . . . CC support is forum only.

CF Tech


Here is a utility that just continously sends key update packet to the CFA-631.


0) (edit) Stop any other LCD software (CC1, CC2, Smartie etc)

1) CHANGE YOUR CFA-631 to COM5 (sorry about that)

2) unzip the utility, change to the release directory and execute the EXE

The display will show key counters. These should start at 0 and go back to 0 any time no keys are being held down.

The display will also show the total number of updates. If the counter rolls over, it will show that on the PC.

Let this run for 24 hours. If it does not show any errors on the PC side the you can assume that the driver and hardware are fine.



New member
Thx CF.

I will check this out when I get some time. In the meantime, I have went back to trusy old CC1..

The buttons are what I really want to use anyways, and they are limited to one function that I dont need....

It does look as though this pretty little display will end up in my media pc scrolling some winamp info with CC1.

I love the display, but in the future I think I will have to shop around for something that has buttons that work out the box. Had I researched some, I would have went with the matrix orbital, and tossed out the cdrom in this shuttle. I dont have the time to be an uberl33t casemodder .

I think you guys are on the right track, buts its a track I wish Id stayed off of....

Sorry guys...


New member
And I will still have a display that will need it.

And I understand yours as well. I work with the software developement team at work on a daily basis. Its near impossible to sort out a small issue such as this, when so very few have the problem. And even more so, when you dont have the hardware in front of you....

I just wish I had to time to screw around with it more... I certainly have the knowledge and intellegence to sort it out. Oh well.

Keep trying. It will be worth it in the end.


New member
Ok I decided to wait and reply to your posts CF Tech until I gave your hammer file a test. So I downloaded the Hammer file and been using it for basically 48 hours.

First I know you replied to Vexter reference this and stated you were frustrated. But I also was frustrated and have already voiced why. As to some of your remarks in the post, well I will just pass it all off as frustration and wont reply to it. As you were frustrated and so was I, but continuing by harping on the small things will not get anything resolved.

So I'll end that there and move on to the hammer test. Been running it for basically 48 hours straight. During the first 24 hours I actually had the time to run some of the software I was running normally. All went well..

The read out as I write this post is as follows:

UD = 0 LR= 0
EC = 0 T = 738970

The T has flipped a couple of times.
The rest of the identifiers have never had anything other than 0 in the field when I have checked up on it.

But during the testing i have had no problems w/reset or back to boot screens or anything. The LCD has been working fine with the hammer test.

So I have to agree w/Vexter which is go back to CC1 for now. If you have anything else you think of that could get to the root of the problem and help you figure it out let me know.

CF Mark

Just to verify...

All of you having the problem are using a 631?
You are not having the problem with the 632, 633 or 634?


New member
631 here. Using the USB header on the mainboard. Ive got the Shuttle SNG45v2 XPC. Im using the latest drivers from nvidia with xp pro sp2. Im also tried the newer drivers for the display linked elsewhere in this forum.

Im subscibed to this thread.

btw, I will be running that little test app you posted this weekend, as Im not in a position to let it run for 24 hours until then. (I carry this xpc to work with me daily)

CF Tech

Batdive & vexter: Thanks for running the tests.

24 hours is not like, strictly necessary, you just want to run it much longer than the time it takes to crash under CC2.

The counters will change if you press and hold a key, but should change back to a 0 when the key is released.

Mine has been going for a 3 days, no problems here.

So my guess is that somewhere in CC2 a ball is getting dropped. Obviously not very often . . . but sometimes it must be missing something.