• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Is my CFA635 TMF KU DOA?

Slashweep

New member
Hey Guys,
I got my CFA635 in the mail today and well how do I know if its DOA? (I feel like a newb asking that) I first tryed it on my laptop first and then on one of my desktops both have the same results. The computer installs the drivers and all and when running the 635_WinTest_1_0.exe it just sits saying "Looking for module...". Thats pretty much it, the lcd just sits there blank, I would hope then it just being connected to power would show some idiot light that its working... but there is no manual and I don't know if I need to send a "wake up or turn on" type command first or hit one of the keys on the lcd board.
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Tech

Administrator
With the right driver, it should power up when you plug it in.

Does it show up in device manager? There should be two places in device manager:

 

CF Tech

Administrator
Hmmmm.

Does COM2 show up in the list of ports for 635_WinTest?

The baud should be 115,200

After that . . . I don't know. I guess I'll have to get support to get a ticket going for you.
 

Slashweep

New member
I double checked my com settings from some of the linux guy posts. I get the same type "error / not working" on both my desktop and laptop. I attached a photo of the 635 tester app.
 

Attachments

starlon

New member
I have the exact same problem.

I don't have the SCAB connected at the moment though. I was planning on installing everything tomorrow. Could that be causing this?

Should the display light up at all? Mine's black.

Edit: It's working now.
 
Last edited:
USB LCD Displays - Graphic and Character LCDs with a Keypad

CF Support

Administrator
If you ordered a SCAB at the same time as the part, can you make sure that power is connected to the SCAB, and the SCAB connected to the LCD?
 
Top