• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

ERROR init_lcd: could not init the com port

I've recently upgraded to Windows MCE from Win2K.

I had both the old 633 service and CC2 working under Win2K.

Most of the time now when I boot windows my 633 does not get initialized. The CC2 icon is in the taskbar blue, and CC2 is running. All I have to do to start the module is right click on the icon and "Restart CC2" and the module starts up fine. This is always the case. It is a minor nuisance to have to restart CC2.

The difference that I have spotted between a good boot and a boot is the appearence of the lines
Mon 30 13:17:20 ERROR init_lcd: could not init the com port
Mon 30 13:17:20 ERROR init_lcd: could not initialize the lcd module on port
in lcd_633.log.

Were I working in linux I might try: compile the com port module into the kernel instead of as a module, move the module init downstream in the innit.d heirarchy, or put a "sleep (1); try_again()" or so somewhere in the module init sequence.

But I don't know windows configuration at all well. And so maybe I'm on the wrong track too, like there is some other error in my CC2 setup.

I deleted all *.log files in the CC2 directory and rebooted, everything worked fine. Rebooted and it didn't start. Those two boots are in the attatched logs.
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

Attachments

CF Mark

Administrator
It sounds like the CC2 service is trying to start before the USB drivers have been initialized.
Try turning off "Start service with windows" in the CC2 options, then start CC2 manually using the tray icon.
Ill be interested to see if it fails to find the com ports then.
 
The principle you mention sounds solid if the fact that I'm using a 633 on a COM port is significantly analagous to a module on the usb port. Or is there something in the logs I posted that said CC2 failed because it could not open an irrelevant USB port? Is there some setting in windows or the CC2*.ini files that would set CC2 to skip everything USB?

It occours to me to check the bios to see if the COM port has configuration options. Maybe it is a 'legacy' device that is not automaticlly enabled.
 

CF Mark

Administrator
Oh sorry, i assumed you had a USB LCD.

Serial ports should definatley be init'ed before CC2 is, so i wouldnt think thats the problem then.

Did you try stopping CC2 from running at startup and then trying to start it from the tray icon?
Im wondering if it always fails on first try, or if its just during early boot.
 
Top