• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Cfah2004a-rmc-jp Prob

Shnyzx

New member
I just reacently got my CFAH2004A-RMC-JP 20X4 LCD and After wireing it 3 times, and double checking the wiring 6 times only the backlite comes one (and is adjustable). Also it gets really hot... need help plz...
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

PaNiC

New member
quote: "have someone else check your wiring"

If it gets hot it's without much doubt the wiring...
 

Shnyzx

New member
Ok 2 other peeps checked the wiring and its' ok. It initializes but as soon as windows starts it goes blank.
 

Shnyzx

New member
to 15 and 16 i got them hooked to the 100k. and by going blank when windows starts I mean only the backlight is on....
 

CF Tech

Administrator
Pins 15 & 16 should go through Rlimit to the 100 ohm pot:



Rlimit for a CFAH2004-RMC-JP should be 25-30 ohms.

Did you try using CFAH_WinTest to verify all the lines individually?
 

CF Tech

Administrator
Use the little buttons on CFAH_WinTest to put all the lines low except one.

Use your volt meter at the LCD to verify that all the lines are low except the one that is set to high in CFAH_WinTest.

Repeat for the remaining lines.
 

Shnyzx

New member
Alright so all of the data lines check out OK, so I'm guessing it's gotta be within the "pot" wires (1-3). Faulty wiring somewhere then right?
 

Shnyzx

New member
I confirmed it even more, it seems the 10k pot isn't working, so.... I gotta get a new one tommorrow and we will see if that fixes my prob. How do u fry a pot anyhow?:confused:
 

CF Mark

Administrator
Shnyzx said:
I confirmed it even more, it seems the 10k pot isn't working, so.... I gotta get a new one tommorrow and we will see if that fixes my prob. How do u fry a pot anyhow?:confused:
Quite easily if you wire the wiper to the wrong place.
 

Shnyzx

New member
ok the new pot didn't do anything.
Just wondering does each pot control?
But I am like 99% sure that the prob is w/in the pots.
 

CF Tech

Administrator
To check the contrast pot's operation, connect your voltmeter between ground and pin 3. Rotating the pot should change the voltmeter's reading from 0v to 5v. Leave it set at 1v for starters.
 

Shnyzx

New member
would it be bad it instead of a 100 ohm pot I used a 100K ohm?
And could I wire it w/o the 100 ohm pot?
 
Last edited:

Shnyzx

New member
I got the 100 ohm pot in now and Rlimit of 25 and everything is wired correctly (i think) and all It does when I turn the 10K pot is stay near 5volts.....help...gasp....air....errmmmmmphhh.....
 

CF Tech

Administrator
As a test:

Connect the outside terminals of the pot to +5v and Ground, respectively.

Leave the center pin (the wiper) disconnected.

Use your DMM to verify that turning the pot changes the voltage seen on the wiper.
 

Shnyzx

New member
I think it's dead.... what should I do?
There has been nothing since the other day when it just worked for a sec and then died....:(
 
Top