• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CFAG320240 Noise

topangea

New member
Hi all,

I'm using a CFAG320240 display and have had it working great. Initially I had it up an running with a PIC and had a touch screen panel interfaced with it and all. I recently ported everything over to the AVR and I have since noticed a substantial amount of noise from the LCD feeding into my setup.

I'm getting 25-27MHz ringing on all lines, some have a greater amount of noise than others. On the reset line for example, the ringing is over 1Vpp, lasts for about 500ns before it dies out, and occurs every 14.4ms. Is anyone else having any problems like this? The LCD works, but the noise couples into a bunch of things. It's coupling into the touch screen controller so much that I have to put a 10nF cap on the /PENIRQ line to keep it from trigging an interrupt.

All noise goes away when I remove power to the LCD btw.

cheers,
-top.
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Tech

Administrator
Can you put a decoupling cap (say 0.1uF in parallel with a 10uF) right at the power terminals of the LCD?

What is your physical connection like (cables, etc)?
 

topangea

New member
CF Tech said:
Can you put a decoupling cap (say 0.1uF in parallel with a 10uF) right at the power terminals of the LCD?

What is your physical connection like (cables, etc)?
I have a ribbon cable about 5 inches long into a breadboard. I have decoupling caps (tried many different combos) as close as possible to the power connection on the breadboard.

Ahhh!!!!!!!!!
 
Top