• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CFAG160160B display flicker (noise on Vo)

jpcooper

New member
I've hooked up a CFAG160160B to a P18F4520 an have the necessary graphics routines working well. However, my display has a slight flicker. I don't beleive this has anything to do with reading/writing of the display as when the pic is idle the display is still flickering. Looking at Vo I see that it has about 0.5V of random noise. As per datasheet it is set for ~-12.4V from the Vee output using a 10K pot. Looking a Vee, apart from high frequency noise, this is clean. So to is the Vdd supply. I'm still able to develope my application but it would be nice to solve the flicker problem. Any suggestions are welcome!
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Tech

Administrator
To make sure the noise on Vo is the trouble, please try one or all of these:

* add some capacitance between Vo and Vss (try 0.1uF in parallel with 10uF for starters)

* use a clean bench supply to drive Vo temporarily

If the flicker goes away, then you know that the noise on Vo is causing the trouble.
 

jpcooper

New member
Thankyou for the suggestion. Adding decoupling to Vo removed the noise along with the LCD flicker. Is this the expected behaviour of Vo?

Also the contrast on the display is not very high. Adjusting the 10K pot connected to Vo does really increase it - any suggestions?
 

CF Tech

Administrator
If the cap fixes it, then the simple answer is "you need the cap" :( . . . . to be exact we could do a whole bunch of debugging with a scope and determine the source of the noise, but there is a good chance that end solution would be to add a cap ;)

Does that display have a "Vee" pin? Is the pot connected to it? You generally should be able to use the pot to set the display anywhere between "too light" and "too dark".
 
Top