• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CFA635TMFKS1 not responding to "example-635"

nevada

New member
CFA635TMFKS1 is not responding to "example-635" program (Crystalfontz example code for Linux).

Previously a CFA633-YYB-KS was attached to the same serial port (at that time the port was set to 19200 baud) and the Crystalfontz example Linux program "example-633" functioned correctly (and it still does when re-connected to test).

The CFA635 was connected using the WR232Y22 serial cable and the included power cable, the serial port has been configured to 115200 baud. The following command:

example-635 /dev/ttyS0 115200

runs, indicates that the port is opened at the correct baud rate, then ends with the following;

Serial_Init:: success
"/dev/ttyS0" opened at "115200" baud.

Timed out waiting for a response.
Timed out waiting for a response.
Ctrl-C to exit.
Updated display, now waiting for packets

(nothing happens past that). Any suggestions? Thanks in advance four your help!
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Support2

Administrator
I'm assuming that the module powers up fine, it's just not talking?

Here's a quick list of things to try:

  1. Make sure the Y22 cable is correctly connected. Ensure that the you have the end of the cable with the single header connected to the CFA635 daughter board. The red wire should be at the top when you connect it to the 10 pin header. For the other end, double check your system board pin out and use the appropriate connector. The pin outs of the Y22 are on the cable's Dimension tab:

    http://www.crystalfontz.com/product/WR232Y22.html#drawings

    Once you verify the cabling, or make any necessary changes, try connecting again. Cabling sounds simple, but is often the culprit (from personal experience ;) ).
  2. Next, try connecting at 19200. The module may be in an odd state where it does not want to fire up at 115200. If you can get it to connect at 19200, then you can set it to start up at 115200 by sending the module a command 33, data length of 1, and a data of 001 -- /033/001/001
 

nevada

New member
Yes, it powers up properly and shows the Crystalfontz splash screen...

1. As for the cabling, the red wire is oriented at the "1" end of the 10-pin header; the Y22 cable works fine with the CFA633 in this orientation when I reconnect it, as does the previous 10-pin cable. (neither get the CFA635 working).

2. I've tried connecting at 19200 baud and the results are the same. I will try the Windows example software and see if that makes a different.

Thanks!
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

nevada

New member
CFA633 not responding, tried on second PC

I installed the "635_WinTest_1_0" software on a Windows PC and connected the 635, but when the software runs it never gets past the "Looking for Module..." message.

I connected my CFA633 to the same serial port and it is found by the 635_WinTest_1_0" software.

I didn't think to mention it before, but when the CFA635 powers up the bottom line of the screen it displays reads: "F4P/F4T Serial Load". Is that normal?

Anyway, I'm running out of things to try. What now?
 

CF Support2

Administrator
Powering up with "F4P/F4T Serial Load" on the bottom line is correct. This is how we identify that the serial firmware has been loaded. What it signifies is that Fan 4 is disabled for the serial communications.

By default, the module should operate at 19200, and then you can tell it to operate at 115200. The modules are tested and ran through our QC process prior to shipment. I am wondering if something has happened to the CFARS-232 daughter board and is no longer communicating properly.

At this point we need to move this into a support ticket. If I could have you fill out our on-line RMA form, we can get things rolling to get you taken care of:

http://www.crystalfontz.com/rma
 
Top