• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CFA-635 and USB power

Chris Hamlett

New member
Hi, I'm having a problem with powering a CFA-635-TMF via USB.

If you don't want to read all the stuff I tried, here's the summary: With only USB plugged in, the device doesn't appear to fully work. With the SCAB powering it, it works fine.

Here's the details:

When I use the display alone plugged into an external USB port (via the WR-USB-Y03 cable), the four blue arrow LEDs light up (although they do not appear to be at full brightness), and there is a dim glow to the display. No text can be seen and none of the bicolor LEDs light up.

The operating system does, however, recognize that a USB device has been plugged in. Under Windows I'm prompted for drivers, and under linux dmesg reveals:

ftdi_sio 1-6.2.2:1.0: FTDI USB Serial Device converter detected
drivers/usb/serial/ftdi_sio.c: Detected FT8U232AM
usb 1-6.2.2: FTDI USB Serial Device converter now attached to ttyUSB0


Using lsusb I get:

Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 011: ID 0403:fc0d Future Technology Devices International, Ltd
Bus 001 Device 010: ID 03f0:1204 Hewlett-Packard DeskJet 930c
Bus 001 Device 008: ID 05e3:0606 Genesys Logic, Inc.
Bus 001 Device 005: ID 045e:00db Microsoft Corp.
Bus 001 Device 003: ID 046d:c01b Logitech, Inc. MX310 Optical Mouse
Bus 001 Device 002: ID 413c:0058 Dell Computer Corp.
Bus 001 Device 001: ID 0000:0000


Linux also creates a /dev/ttyUSB0 device for me. But that's as far as I get, the device does not appear to generate or respond to commands sent over USB. The linux test program fails with:

chamlett@localhost ~/tmp/635_linux $ ./test635 /dev/ttyUSB0 115200
Ultra-simple CFA-635 command-line communications example.
Crystalfontz America, Inc. http://www.crystalfontz.com

Usage:
./test635 PORT BAUD
PORT is something like "/dev/ttyS0" or "/dev/usb/ttyUSB0"
BAUD is 19200 or 115200
To clear the display, enter "clear" as an optional third parameter

Serial_Init:: success
"/dev/ttyUSB0" opened at "115200" baud.

Timed out waiting for a response.
Timed out waiting for a response.
Timed out waiting for a response.
Timed out waiting for a response.

Ctrl-C to exit.
Updated display, now waiting for packets


It never receives any packets. We also have some custom code we've written that also fails to receive any response from the device. Under Windows, the 635 test program status is always 'Looking for module...'. We've installed the 635 Windows drivers and both devices are seen under Device Manager.

However, if I connect the SCAB and power it via a regular power supply +5/+12 connector, everything works fine. LEDs are at full brightness, the test linux program can set text and respond to button presses, and our code is happy with the device.

I've tried it on three different machines (two linux, one windows), both with a powered USB hub and a direct connection. Oh, and just to be sure, I also tried the WRUSBY11 cable and directly connected the device to a motherboard header. Same results.

So my question is: is it likely there is a problem with the device, or is there some mysterious USB issue I should look into?

Thanks for your help,

Chris
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad
Top