• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

cfa-631 locking up

hmboy

New member
Hey guys, i recently bought a cfa-631.

It locks up after 4-48 hours.

When this happens, fan speeds all goto full, the screen doesnt update (it stays on the last thing sent to it).

If i shut down the service exe the CC2 icon goes red, but cannot restart.

If i try to then disable the device in device manager, device manager locks up.

reboot of pc fixes.

I have tried both onboard USB headers, tried re-installing drivers, tried com3 + com4, tried highest speed for the com port..

All to no avail.

Using latest usb drivers + latest cc2.


Advice?
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

CF Tech

Administrator
Sounds like it might be a defective module, it looks like you have done a lot of debugging. However, the "fans" going to 100% would indicate that the fan fail-safe (which CC2 enables) has triggered. This would be typical of a program hanging. Also, the trouble shutting down CC2 is worrisome. That stuff could be explained by some kind of flakiness in the USB connection though (neither the module proper of CC2 at fault).

Can you try one more thing for me?

a) Stop/close CC2.
b) Grab 631_WinTest
c) Open the packet debugger (so you can see activity)
d) Open the temperature window, turn on reporting (assuming you have sensors connected)
e) Open the fan window, turn on the tachs set the fans to something reasonable, but not 100% (so you can tell if they go to 100%
f) Let that run for a couple of days, and see if hangs up

If that test runs perfectly, then I would think the hardware is OK. If that test goes south, then we can replace the module.
 

hmboy

New member
Okay, shut down cc2 service.exe - CC2 icon goes red.

Shut down cc2_config.exe - red icon goes away.

LCD still display last thing sent to it (frozen, fans still at 100%).

run 631 wintest - Communications port pulldown menu - Crystalfontz CFA631-USB (COM4) (in_use).

Its saying its still in use.



I am very worried that if i have to replace it due to warranty, that i have to pay all the shipping as i am in australia, and that would equal about $60US just to claim warranty, half the price of the lcd itself! :eek: :eek: :confused:


-edit-
I just tried to disable it after all that in device manager, and it says i would have to restart my pc just to disable it(that was the com port).

Then i went under usb - and tried to disable crystalfontz and now my device manager has completely locked up for over a minute as i type this.

-edit-
rebooted pc, turned off cc2, started up wintest, set custom text and all fan speeds to 50%.

I'll leave this for a couple of days. More often its closer to the 4 hours then the 48..

If this fails, ill try the external usb cable.

If that fails, ill try a different PC...

Not looking forward to paying half the price of the lcd to claim warranty though, thats for sure :mad:
 
Last edited:
Top