• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CC2 Vista64 Strange Behavior

Clump

New member
I have a CF631 with internal USB interface and SCAB.

I just made the leap to Vista 64. Downloaded the latest USB drivers and CC2 and got everything working. I also followed the guide to get CC2 to start on boot and it all seems to be working fine.

Here's the odd part - After being in Windows for a while (it seems somewhat random, but no more than 10 minutes or so) CC2 seems to quit working. My SCAB controlled fans all spin up to 100% and the display stops wherever it happens to be. The CC2 icon in the system tray doesn't change and the update count keeps going up. Restarting CC2 has no effect.

If I go in and do Add/Modify Module it has the following: "Note: CrystalControl2 is not currently running, or is not configured to use this LCD module. Any new attached temperature sensors cannot be configured until you click the "Add/Modify" button below and then restart CrystalControl2."

Rebooting will put it back to normal, at least for a few minutes.

This is a new motherboard and CPU, everything else is the same hardware, including the CF631, that ran fine with XP 32.

I have also tried manually stopping and starting the CC2 service. It makes no difference. The only thing that fixes it is a reboot.

Any suggestions are appreciated!
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

Clump

New member
I have uninstalled and reinstalled CC2 a bunch of times. Stock clocked, over clocked it doesn't seem to matter the problem persists.

I finally solved it - I removed the CFA631, plugged the fans into the motherboard and am using speedfan to control them. My CFA631 makes for an expensive paper weight.

The lack of support from Crystalfontz is amazing. I posted a plug in request last January (yes January!) that has yet to be responded to. Over 24 hours later no response at all to this problem. Not even a "go away we don't care". There are lots of posts where Crystal Control Admin either never responds or responds months later after another user tried to help.

I'm not that annoyed by having a problem. I'm really annoyed by being ignored. It's a bad way to treat paying customers. The good news is that my paper weight is working perfectly and I won't have to ask any more questions that get ignored in the future.

Good luck to all of you who keep plugging away with these devices.
 

reider

New member
With the very greatest of respect, I do not represent CrystalFontz in this reply, even as a beta tester. This is a personal reply in the forum.

(1) I have looked through your previous messages and you seemed to be pretty happy with the 631 until now, I can only go by your comments. Perhaps your current problem is adding to your frustration and leading to the pointed comments.

(2) Your plugin request wasn`t answered, but this very same question has been answered time and time again, the search facility will show this. The Scab works with the module and CrystalFontz, it does not work with Speedfan, nor MBM which is unsupported now anyway. In all likelihood it never will be used in conjunction with third party software.

(3) I originally left your message unanswered as there has been a problem with some cables connected internally. You will see this on the forum, using search, it is still being investigated.

Reider
 

CF Mark

Administrator
Besides the lack of fan control from outside temp values (it has been said before, this wont be supported), everything was good until you upgraded to Vista 64?

Your current problem (which you only give us 1 day to reply to?), is either a Power, USB cable or USB driver issue.

This problem comes up quite often, and as far as i can tell, it is not CrystalControl2 at fault.
What happens is either noisy power, an bad USB cable/cable-connection or driver issue causes the USB drivers to simply stop working.
Because of this CrystalControl2 simple cannot do anything with the USB port until Windows has been restarted.

I have tried to find software solutions to this many times before with no luck.
Best advice i can offer you is to try using a different floppy power connector, try re-routing the USB cable through your case, try a different motherboard USB header, and failing all those try a new USB cable.
 

CF Tech

Administrator
If you do think it is a hardware issue, please call or write support, they should be able to resolve it.
 

Crystalmancer

New member
I was having the same problem when connected to the internal USB headers on my motherboard. It worked fine for months, then I started getting the lock-ups on the 635

When I used the USB external plug, everything was resolved.

If you are connected internally, you might want to give this a try and see if it fixes your prob.
 
Top