• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CC2 no LCD output after windows start

moon261

New member
hi

iam using cc2 v.20070720, winxpsp2, and a 40x4. the whole programm and the display itselfs works fine.

but

if i start windows completly new there is no error and the display shows nothing. the icon of cc2 conf is blue and it says "running". but nothing is shown on the display. but if i click "restart cc2" then it shows all correct on the display. the same result i get if i restart the service in windows manually. after its done everthing is shown on the display as it should.

i try to reconfigure the service in windows but it dosnt helped.

thx for help

edit: i tryed v.20070812 ....and its the same problem
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
Last edited:

moon261

New member
i have logged a startup without restarting the service.

i think interesting is this.
NOTICE 20070716-144136-0.000562s log_start#159: Logging started
NOTICE 20070716-144136-0.015095s ini_check_section#329: section found: module00
NOTICE 20070716-144136-0.015241s ini_read_dword#501: value found: module00->id = 2615403304
NOTICE 20070716-144136-0.015375s ini_read_word#671: value found: module00->port = 43008
NOTICE 20070716-144136-0.015508s ini_read_bool#826: value found: module00->slow = FALSE
ERROR 20070716-144137-1.467493s start_driver#166: cc2_io driver could no be started (err=41F)
ERROR 20070716-144137-1.468077s init_lcd#261: error initilising the lcd module


maybe it cause my lpt controller. iam using a PCI-E to lpt controller. and it is using the adress range 0xA800-0xA807 and 0xA480-0xA487. i have problems with cc1 so i used cc2 cause there i can type the E/A adress manually. and until ive done a update to actual version i have no problems. maybe it depends on ....before the last windows installation the controller card uses a E/A range starting at 0x9800. how sayed i have problbelms with cc1 and other display programms cause they dont reach this port adress. but the old cc2 version has no problems with 0x9800. maybe the old version would also make trouble with the now used range if 0xA800 it dont tested this.

and before u suggest i should change this lpt adress range ....i would surprised if u could tell me a way to change it. i asked the manufacturer of the card and they diddnt understand me or they dont know how to do that. and to change it in the windows device manager its not possible cause the options are all deactivated.
 

Attachments

moon261

New member
i dont know why directly but it seems to be working properly. i have changed nothing in the programm itselfs or the service.

the only way what i can imagine is ....i wasnt ready with installing all the programms i need as the cc2 fault appears. so by the time i have installed more programms which need to load at the startup. maybe its only a timing problem in the cc2 service ? maybe it was loaded and ready but had missing other windows things which are not loaded at this moment ?
 

CF Mark

Administrator
Maybe the PCI cards drivers were loading up later, but thats now changed for some reason.
Either way, good to hear its now starting first time.
 

moon261

New member
it sounds like a good assertion. and i think thats it... if you didnt find any other problem in the log files.

now ...thanks for help ....but now i have other problems ...maybe the balance for the time cc2 worked fine :)

sorry to bother you with the next problem

Link to the new thread

maybe you read it already
 
Top