• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CC2 keeps crashing when starting service

raging_bull

New member
I Finaly made my 20x4 characters LCD to work. At least, it works fine with crystalcontrol1 and smartieLCD.

But, when I install CrystalControl 2 and add my lcd module and then start the service it crashes. I tested CrystalControl 2 on 2 computers, both have the same problem.. I have no idea what the problem is.. The strange thing is that it just doesn't work on 2 different computers.

Anybody knows what the problem might be.?

Maybe this memorydump helps. http://www.ragingb.com/upload/files/1/memdump.zip
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
Last edited:

jc634

Administrator
Questions:

1. OS? 32 or 64-bit?
2. USB or Serial?
3. If USB, what is the USB drivers version?
4. CC2 version?
5. I assume that CC2 crashes w/o any screens? Correct?

Close the tray app. Go to Control Panel -> Administrative Tools -> Services. Look for CC2Service. What is the Status and Startup Type? Highlight it and can you start the service here?

This is a begining list of questions.

Also, look thru this this thread: https://forum.crystalfontz.com/showthread.php?t=4418 for additional questions/troubleshooting info.

Hopefully, answers to the above will help to pinpoint the problem.
 

raging_bull

New member
I am using Windows XP pro fully updated 32bit, on both systems. I connected my HD44780 display to the LPT-1 interface on my motherbord on both systems. System 1 uses 0x378 and system 2 uses 0x278. The build of Crystalcontrol 2 is 20070812 / 928.

I tried to start the service manualy, but it still crashes 1 second after it's started. I also tried multipile settings in crystalcontrol 2 like Port Speed Slow and Fast. And some option "Alternate Enabled" checked it and unchecked it, it didn't make any differnce.

Also I did that lil thingy with the log files, here they are: http://www.ragingb.com/upload/files/1/logs.zip


I am going to find out now if maybe an older version of CrystalControl 2 works on my computer.
 

raging_bull

New member
Ok, thanks anyway for trying helping me out. I allready helped myself out.. I use now LCDSmartie. This one has a BS Player plugin. Now i have exacly what I need.
 
Top