• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CC2 does exactly nothing on serial display

Bluescreen

New member
I just tried CC2 for the first time with an serial 634 LCD. It does exactly nothing. So I connected a serial port tester and look what happens.

During system startup (not when restarting CC2) there is some activity. The display's upper line becomes filled with 'G'. The activity stays until I log on to WinXP. Then there is only silence on COM2.

I got the following error in service log:

Tue 22 11:02:16 ERROR init_modules: error initilising module (ID = 1681028140)

I connected the display to COM2. There is no other software running which is using COM2. The system is WinXP and the display is an 634, so the "old style" protocol is used, not the new packet oriented one. For simplicity I just installed the date/time screen.

When I connect Hyperterm to COM2, the display works as expected.

Does anyone have an idea, what's wrong?

Bye
Bluescreen
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Mark

Administrator
Edit "lcd_634.ini" in the cc2-service directory.

What does the port="xxx" line say?

Try changing it to:
port="com2"

Let me know how you go.
 

Bluescreen

New member
Here is the lcd_634.ini

[module00]
id=1681028140
port="\\?\acpi#pnp0501#2#{86e0d1e0-8089-11d0-9ce4-08003e301f73}"
speed=19200

But it seems, that's not the problem. I got it running by restarting the machine after reconfiguring the display type.
The mistake I made was at the beginning I selected a wrong display type (633). As nothing happens I looked through the config and saw the mistake. I deleted the display and added the correct one. Then I restartet CC2 but that doesn't change anything. Only restarting (including power off!) helps. Now it works.

COM2 in the ini file works, too.

Thank you for advice.

Bye
Bluescreen
 
Top