• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

CC2 constantly crashing

irish56_ak

New member
I have the CF634 USB drive bay kit. It constantly crashes. Sometimes I can restart it, other times I have to restart the computer. This is on a clean install of Win 7 Pro 64 (2 days). I can't get the USB drivers downloaded from this site to load properly...The instructions show 'Crystal Fontz CF634 USB' should be listed in Device Manager under USB Controllers - it's not. CC2 shows it's using COM Port 3, and in Device Manager it shows up under 'Ports' (see attachment). If I uninstall the default Windows drivers and try to manually install the CC2 drivers, I can't get the LCD to run at all, even though it is listed (under Ports) as a CF634.


Of the 337 listed events in the Event Log, all but 4 are CC2.
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

Attachments

flux

New member
Try this

"First, make sure CC2 is stopped (kill the cc2_* processes in task manager if you need to).
Open up "C:\ProgramData\CrystalControl2" in Explorer (itll be hidden, you may have to enable show hidden & protected folders in explorer to get at it), and delete everything in there.
Reinstall the latest CC2 setting it to run as a tray application as advised, then reboot.

After reboot CC2 will have a clean slate and should work properly.
If your still having issues, let us know."

CrystalControl Admin gave me this answer two weeks ago and it worked perfectly.

Also, make sure you've hunted down the newest version of cc2 - 20110121, I believe. It's buried here on the forums (why it isn't linked under Related on the main Crystalfontz site baffles many a mind, I'm sure.)
 

flux

New member
Oh, and

I'm still getting the netscreen & keyboard errors in evenvtwr, but it doesn't seem to affect anything (not that I've done a ton with cc2 yet - sorry to say community support is a little...lacking.) My own device manager shows essentially the same - CFA635 on COM3. In my case, cc2 worked initially and then bugged out (which may have been my own inadvertent doing.) CC Admin gave me the above reply after I had tried everything I could think of - I didn't realize that the uninstaller doesn't perform a full, clean, uninstallation. CCleaner wasn't finding that folder, either, although it did catch a couple things in the registry, iirc.

Good luck - I'm hoping there's some magical Google-fu I'm missing to find a trove of information on these. Sadly, it seems there was a fascination with these a couple years ago that has since died out. I've managed to mod a couple .2004 screens to do what I like, but there are some gaps, definitely. I still can't get any Rivatuner-like programs working with cc2, and that was a huge part of why I wanted an lcd display in the first place. I've got CoreTemp not-quite-working (works right in the config screen, but not on the lcd.)

You might also try LCD Smartie - it's reputation was huge back in the day, but support died years ago. I couldn't get it to work with my 635 at all, but ymmv.
 

irish56_ak

New member
I read your thread, but I did a complete reformat of my disk and reinstall of Windows and CC2 and immediately had the same problem as I was having before. The LCD is running, and staying up longer, but I'm still getting random freeze ups. I'm hopeful that I can get some advice on installing the USB drivers, as the LCD is not showing up in Device Manager at all. It is running as a tray application, and I did not try to install it as NT. All the Side by Side errors (see attachment in original post) are CC2 events (conflicts) from the WinSxS folder. Thanks for the reply.
 

irish56_ak

New member
No problem. I did as you requested. The instructions said to start a new thread, so I did that instead of posting the zip file here.
 
Top