• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Broken CFAH4002A-TFH-JT?

Mart

New member
Hi,

I am using an seeeduino mega and the liquidcrystal library to drive a LCD. I have the following output:




video:
http://step.polymtl.ca/~kmart/100_4063.MOV

Sometime it does print "ALLO" (even if the pic is not clear). If I swap a VFD (HD44780 compatible controller), it does print "ALLO" correctly without the blur.

Is my lcd toasted??

thanx

Mart
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
Last edited:

CF Tech

Administrator
First guess: It looks like it was disassembled and then re-assembled incorrectly--the zebras not making good contact.

Other possibility: Some kind of electrical damage (ESD, over voltage, reverse voltage).

Or it could be that there is something wrong with the initialization or the Vo (contrast) setting.
 

Mart

New member
Hi,

thanx for the reply. The unit was not dissambled but can you tell me where are the "zebras" located?

First guess: It looks like it was disassembled and then re-assembled incorrectly--the zebras not making good contact.

Other possibility: Some kind of electrical damage (ESD, over voltage, reverse voltage).

Or it could be that there is something wrong with the initialization or the Vo (contrast) setting.
 
The zebras are strips of alternating plain rubber/conductive rubber, and they are under the metal shell, between the LCD glass and the PCB.
 
Top