• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Accessing serial ports on the CFA

Shaunr88

New member
Hi,

I'm trying to program the serial ports on the CFA, but I can't figure out which /dev file maps to the ports. Is there a default? Or do I have to run some kind of command?

The typical /dev/ttyS# isn't showing up except for 0 which seems to be where the USB console goes.

Thanks,
Shaun
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

Shaunr88

New member
Ok, another question about serial ports (and programming the CFA in general).

I have a piece of code that sends some data out of the serial port to a modem. I run this code on my laptop (running debian) and on the CFA. I've verified that both are outputting the same data by plugging them into another machine running hyperterminal and capturing the output.

However, with the laptop, the modem responds while the with the CFA it does not. With the laptop, the modem shows DTR and RTS leds lit up and with the CFA those lights are dark.

I've tried to use a function in termios.h, ioctl() to set the DTR bit, but the appropriate constants weren't defined in my include file. I tried to include another file that does have the appropriate inputs, <asm/termios.h> and <linux/termios.h>. The code then behaves oddly and causes a seg fault.

Does anyone know anything about this? Where should I be including files from?

I'll follow up with the code in another post.

Thanks.
 

CF Tech

Administrator
The CFA-910 serial ports do not support the legacy RS-232 hardware control lines.

You somehow need to tell your host to ignore those lines in the software, or you can wire the status line out of the host back into the host so the port always appears ready.
 
Top