• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

A few problems 634 USB

ratz34

New member
I've seen this posted before but it seams that they have been lacking in detail so i'm going to post my version of the 634 USB.

To start off with the 634 USB is plugged straight into the back of the tower in to the Motherboard.

The first time I install the 634 USB it works fine. The problem starts when the pc gets turned off or restarted. After this the CrystalControl software will do one of 2 things. Return a "Stack Overflow" or the CrystalControl software will load but will prompt a message stating that - COM port 3 cannot be initialized - . Wintest prompts a message saying "Could not open any of the serial ports."

After all this I can get it to work "IF / WHEN" (pick a word you want) I unplug the 634 USB cable, wait a few seconds and plug it back in. Then it works fine. Or boot the pc with out the 634 USB plugged in and then plug in the USB cable after I get into windows.

If I'm right this problem did not start for me until after I updated windows xp to the version that prompts you to select a user when windows start. Before windows loaded into the default user, but now (with the current XP updates) forces you to select a user to boot into the desktop. I'm sure that there is a way to disable this.

It would be interesting to see if you can force the drivers NOT to load until after the desktop is loaded and then have the drivers call for the CrystalControl software.

ASUS P4C800 Deluxe Bios ver 1008.004
Intel P4 2.8 HT PAT
2 x 512 Kingston Hyper X
ATi 9700 Pro
2 x Seagate Barracuda ATA V in Raid 0
Windows XP Pro (All current updates)
Crystal Fontz 634 USB (using drivers off of crystal fonts webpage)
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Support

Administrator
Thank you for your recent order.

You should post this in the CrystalControl forum, as they will be able to help you much more with this issue, and is not a problem with an LCD itself, but with the software.

CF Support
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

ratz34

New member
I know that it's not the crystalcontrol software. It has something to do with the drivers not configuring the com ports correctly. Or it's a problem with windows not able to configure fake (USB device pretending to be a) com ports correctly. It has something to do with the how the com ports are int when windows loads. Because for somereason they are locked out untill the device is refreshed.
 

Freak24-7

New member
Ghost devices

Hi there!

I had the same problem, here's how it worked out for me:


This is what happens:


With USB devices WinXP/2K have a habit of not recognizing returning devices.

What I mean is this:

If you plug your USB-LCD in for the first time windows installs it as a new device.

if you then detatch it Windows detects that the device is no longer present and DISABLES it. Note that it DOES NOT UNINSTALL it!!!

If you then plug your LCD back in Windows SHOULD recognize that it's still the same LCD and RE-ENABLE the device again.
Unfortunately a lot of times it doesn't, but installs a SECOND identical device instead.

If you unplug and reattach a device a couple of times you end up having 15 or more identical deactivated devices in your configuration. Since all devices are identical (hence use the same com-port settings, adress range etc.) after a while Windows trips over these multiple configurations (even though the devices are deactivated) and the attached USB-devices start showing very strange behaviour ("Com-Port already in use"/"Device not found"/"High-speed device running on low-speed HUB"...).

Here's what to do (This is for WinXP, it should be similar in Win2K)

go to System Properties by holding the "Windows Key" and pressing "Pause" (located on the top-right), or by clicking your way through "Start/Control Panel/System".
Choose the "Hardware" Tab and click "Device Manager" in the center section!
You should now see a list of connected devices. First open the "Universal Serial Bus controllers" tree (usually at the bottom) and check if your display is actually shown there.
I don't think you actually HAVE do do this next step, but in my opinion it's always a good idea to give "troubled Hardware" a clean start...
If your display does not show up then do nothing.
If your display does show up then right click it and UNINSTALL it!
Just click "No" every time you are asked to reboot! (USB-Devices are all Hot-Pluggable, so you don't have to restart after changing their settings.)

Now comes the tricky part!
In device Manager, open the "View"-Menu and activate "Show hidden Devices"! By doing this you are telling windows to show you ALL installed devices, not just the ones currently connected!
If you now reopen the "USB-Devices"-Tree you should see some devices with greyed-out icons. These are the ones that are not currently connected!

Now UNINSTALL every Device with a greyed-out Icon IN THE "Universal Serial Bus controllers"-Tree and ONLY IN THIS TREE!!!
Some system components are always shown in grey (not in the USB-Tree, though), so don't start uninstalling every grey device you find anywhere! Only do this in the "Universal Serial Bus Controllers"-Tree!!!

If you want to you can look through the other trees as well and uninstall old hardware that might still be in there but is no longer used (like the printer you sold last year or your neighbor's digital camera you borrowed for your vacation). But as I said, be a little careful with that!

It might also be a good Idea to uninstall every device in the "Unknown Devices"-Tree. This tree is used by windows for everything that isn't installed properly. Windows cannot access these devices and hence doesn't use them. Usually it's just garbage, anyway...

After completing this plug in your display and install it the usual way. Reboot if you want, as I said, you don't have to...

reload the Software, make sure the settings are correct.
If the settings are NOT correct CrystalControl will still give you an error message and then a stack overflow, followed by a crash.
you can avoid the crash by clicking away the error message really quickly! CC will still disable the display, but at least you get access to the config and are able to correct the settings!


This is how I got it to work (it got my printer and scanner fixed, too... :)), I hope it works for you!

good luck!


Freak24-7
 
Last edited:
Top