• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

635 linux /dev question

stu_hogg

New member
Hi all,

Looking for some help configuring a 635 under Suse. Am running a stock 2.4.20 kernel on an embedded Via system. USB is configured ok...

bmw:/usr/local/635_linux # lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 002: ID 0403:fc0d Future Technology Devices International, Ltd


The /proc/bus/usb/devices looks correct also..

P: Vendor=0403 ProdID=fc0d Rev= 2.00
S: Manufacturer=Crystalfontz
S: Product=Crystalfontz CFA-635 USB LCD
S: SerialNumber=CF000666
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=490mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms

The display is powered up.

When i try to run test635 i get ...
Serial_Init:: Open() failed
Could not open port "/dev/usb/ttyUSB0" at "115200" baud.

My question is - how do I know what is the correct device file. The /var/log/messages does not indicate what device file the display relates to...

Apr 26 21:47:16 bmw kernel: usb.c: USB device 2 (vend/prod 0x403/0xfc0d) is not claimed by any active driver.

All help appreciated !

Stu
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Web

Administrator
As per your /proc/bus/usb/devices, the required driver module "ftdi_sio" is not loaded.
I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
You can check to see if the ftdi_sio module is loaded by doing an lsmod. You should see something like the following listed: "usbserial ... 26655 ... ftdi_sio".

Linux kernels prior to 2.4.23 did not include this module, so the fact that you don't have it isn't surprising. You can find the driver module and manually install it here: http://sourceforge.net/project/showfiles.php?group_id=32425&release_id=101763

If you have further problems, don't hesitate to let us know.
 

stu_hogg

New member
Hi - thanks for quick response.

I tried loaded the ftdi_sio module, lsmod shows...

bmw:/usr/local/635_linux # lsmod
Module Size Used by Not tainted
ftdi_sio 12092 0 (unused)
usbserial 18460 0 [ftdi_sio]
usb-uhci 22096 0 (unused)
usbcore 57836 1 [ftdi_sio usbserial usb-uhci]

when i plug in the 635 the kernel messages indicate...

Apr 27 18:34:05 bmw kernel: hub.c: new USB device 00:11.2-2, assigned address 3
Apr 27 18:34:05 bmw kernel: usb.c: USB device 3 (vend/prod 0x403/0xfc0d) is not claimed by any active driver.

also /proc/bus/usb/devices still shows none !

I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)

What else can we check ?#

stu
 

CF Web

Administrator
The kernel has to be recompiled (out of my range of experience) with the ftdi_sio module added in order for the usb controller to recognize the lcd module when it's plugged in.

It may be easier to just try and update your current kernel to a 2.4.23 version or later as they will already have the ftdi_sio stuff built in.
 

stu_hogg

New member
ok - I tried passing the vendor / product code on the insmod command, but I get some unresolved symbols. I wanted to build a slimmer kernel for this project anyway.

Will let you know...thanks
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

stu_hogg

New member
I have tested ok with a 2.6.13 kernel on Suse 10, 64 bit. I'll build a custom kernel for the project box...when i get a chance.

thanks again.

stu
 
Top