• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

635 LED's

jc634

Administrator
Want to get your 635 LED's working?

Here is the original example from CC admin. You will need to edit your lcd_635.ini file to include the LED info below. Also, you need to look in your cc2_perfmon.ini file for a variable named \Processor(_Total)\% Processor Time or \Process(_Total)\% User Time. Note the id # associated with one of these variables and copy and paste it over 1500463079 in the led0x_id_value=1500463079.

[module00]
id=1905662952
id_keypad=1905662953
port="\\?\ftdibus#vid_0403+pid_fc0d+6&25509ecb&0&1#0000#{86e0d1e0-8089-11d0-9ce4-08003e301f73}"
speed=115200

led01_order=5
led01_id_value=1500463079
led01_value_max=100
led01_value_min=75

led02_order=5
led02_id_value=1500463079
led02_value_max=75
led02_value_min=50

led03_order=5
led03_id_value=1500463079
led03_value_max=50
led03_value_min=25

led04_order=5
led04_id_value=1500463079
led04_value_max=25
led04_value_min=0

Copy paste, etc., save your ini file and restart CC2. You now have CPU displayed as a bargraph on your 635 LED's.

Questions?

For my 635, I use the the bottom 2 LED's to display CPU usuage and the top 2 to display Network bytes received and sent.

If you want to know how to do this, let me know...

Jim
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

Silver Dragon

New member
hey, thank you for that. it looks awesome!!!!!!!

can you tell me how to do more plase please please!

thank you once agian :)

a very rpoud owner of a 635(also awaiting scab)
 

jc634

Administrator
This is the LED code I use on my 635:

led01_order=5
led01_smooth=7
led01_id_value=381711152
led01_value_max=100000.000000
led01_value_min=0.000000
led02_order=5
led02_smooth=7
led02_id_value=3123086274
led02_value_max=500000.000000
led02_value_min=0.000000
led03_order=5
led03_smooth=7
led03_id_value=1733063910
led03_value_max=100.000000
led03_value_min=50.000000
led04_order=5
led04_smooth=7
led04_id_value=1733063910
led04_value_max=50.000000
led04_value_min=0.000000

LED 3 & 4 are CPU usage. LED 1 & 2 are network bytes received/sent.

About the only thing you need to know are:

1. the id # of what you want to monitor.
2. the min/max values of what you are monitoring.

If you look at LED 3 & 4, you notice the 0-50 and 50-100 for CPU %. For 1 & 2, note the 0 and 500000 min/max values. For bytes, you will need to set the max that corresponds to your ISP service max rate.

More questions?

Jim
 

Silver Dragon

New member
this is too good to be true, i tihnk im starting to get the hang of this. i jsut tried what you told me to and it works excellent. it would nice to have a description next to the LED to say what they are monitoring e.g.

LED1|| Network KB sent
LED2|| Network KB recv'd
LED3|| CPU working >50%
LED4|| CPU working <50%

then followed by bar graphs with the remainder of rows.

i hope that makes sense, im looking forward to lots of things that are possible with the 635, at the moment to much work to do from home. maybe get abit more time when i get my paternity leave ;)
 

jc634

Administrator
LED's are simple compared to keypads command options (see my other thread).

If you think about it, you might be able to understand the complexity of writing a GUI interface to add screens/LED/Keyboard information to CC2.;)

I don't envy CC admin's mission to add the much anticipated upgrade.:D

Jim
 

Silver Dragon

New member
LED's are much easier i think i will try use the first LED for Hard drive access, 2nd LED for Network activity and last 2 LED for CPU. i will to do this. if i can find the time, its almost 12.30am in the morning.

i envy CC admin for what he does and appreciate all the hardwork he puts so that we can enjoy CF products.

i think i will order the daughter board in the next few days and expand my options. right now i am playing with the winamp plugin, but i cant use the keypad to change anything, maybe i havent configured it properly.

i wish i could write a GUI, working almost 50 hours a week, having a pregnant wife and a 15month baby i dont think i could find the energy or the time. maybe when i retire ;)
 

jc634

Administrator
Silver Dragon said:

right now i am playing with the winamp plugin, but i cant use the keypad to change anything, maybe i havent configured it properly.

i wish i could write a GUI, working almost 50 hours a week, having a pregnant wife and a 15month baby i dont think i could find the energy or the time. maybe when i retire ;)
See my post on keypad events, you might need to add the dkc_disable=1 to the cc2_service.ini

Energy and time. Give yourself 10-15 years and you might wish for the good ole days when the kids were less demanding...;)

Jim
 
Maybe it works in yours.
Just installed my USB 635, tested it OK with WinTest, tried LCDSmartie and finally the latest CrystalControl2. Everything works OK, including WinTest showing me that the LEDs work OK.

HOWEVER, followed exactly the instructions by Jim for the LEDs to show CPU use: nothing, rien, nada, niente, nihil, kein. I have nice bar graphs showing the CPU use, but the LEDs DO NOT LIT.

I am an experienced PC professional, so I am SUPPOSED to be able to do something as simple as copying/pasting/saving text .ini files! Maybe I am getting old ...

What am I doing wrong?

Thanks
 

jc634

Administrator
Open the file cc2_perfmon.ini in the cc2_service directory.

You should have something like the following:

[perf00]
id=2223307046
full_name="\Processor(_Total)\% Processor Time"
precision=0
multiplier=1

Note the id # and copy/paste into your lcd_635.ini file. Restart CC2 and all should go.

If not, upload these 2 files and we can take a look. It may be a while before I get back. I have to go to a baseball sqrimmage and 2 games today...

Jim
 

CF Mark

Administrator
Somthing that hasnt been mentioned in here is the values for "ledXX_order".

So, here they are :)

Code:
Black Always = 0
Black to Red = 1
Black to Green = 2
Red to Green = 3
Green to Red = 4
Black to Green to Red = 5
Black to Red to Green = 6
 

jc634

Administrator
LED's tied to screens

I don't think there is any way to do this currently...

Is there a way to coordinate the LED's to a screen? For example, if I have a CPU usage screen up, I would like to display CPU usage.

If I have a HD usage screen up, I would like to display HD usage.

Etc.

This would be particularily neat if tied to a SCAB fan % screen!

I don't *think* we can do now, but perhaps a suggestion for incorporation into CC2 at a later date?

Jim
 

CF Mark

Administrator
You are correct, that cant be done at the moment.

How about this?

Code:
led_select=358738525

ledset00_led01_order=5
ledset00_led01_smooth=7
ledset00_led01_id_value=381711152
ledset00_led01_value_max=100000.000000
ledset00_led01_value_min=0.000000 

ledset01_led01_order=4
ledset01_led01_smooth=2
ledset01_led01_id_value=34534855
ledset01_led01_value_max=100.000000
ledset01_led01_value_min=0
Etc, etc, etc.

You would change the "led set" by using the "led_select" id as an event.
 

jdgordon

New member
that would be sweet... i might just have to move my 635 to a more easily viewable spot.. (im thinking moding my main monitor and putting it in it under the screen... (15" crt))


would that be in the screen file? or the 635.ini file?

while your playing with the led code... can you add a way to turn all (or some) of them off??? (unless it can be done now?).. its very annoying watching a movie with the backlight off but the lights blinking...
________
MAZDA COSMO SPECIFICATIONS
 
Last edited:

CF Mark

Administrator
It would be in the "lcd_635.ini".

As for LED brightness, i could add an option, on or off, to link LED brightness to backlight brightness.
 

jdgordon

New member
hmm.. shame about it not going in the screens... would make it all easier...

speaking of easier... wont having this in the screen files make it easier to play with the leds in the screen editor (when it gets done) ??
________
CHEAP GLASS PIPES
 
Last edited:

CF Mark

Administrator
ATM i cant really see a neat way of getting the LED options out of the 635 ini and into the cc2_service ini.

Does it need to be though?

Really LED setup should go in the 635 config GUI.
 

jdgordon

New member
its 12.30am and i need sleep.. so this idea may not sound as workable as im trying to make it sound.... but...

maybe try something similar to the events... well not really....

in the screens put a [from] section with from="635.ini"
..
eg.. something like
Code:
[from00]
from="lcd_635.ini"
sec="LEDconfig#"
opt01="id=@01"
opt02="led01_order=5"
opt03="led01_smooth=7"
opt04="led01_id_value=@09"
....
opt09="led04_order=5"
opt10="led04_smooth=7"
the id there is the LED group config...

then in the screen you put a line led_config=@01

eg..
[screen]
screen_name="CPU Usage Bargraph"
options=0
alt_delay=5000
led_config=@01


then all that needs to be done is the lcd plugin needs to put the correct config onto the LED's which isnt any harder than your suggestion (i assume its not anyway)


i dont know if this is more work than reward tho if the 635 is the only lcd with leds (unless your trying to push them more than the other lcds....)

(i hope this makes sense..)
sleep time for me now...
________
FFM SQUIRTING
 
Last edited:

jc634

Administrator
CrystalControl Admin said:


Really LED setup should go in the 635 config GUI.
Why? Using your reasoning, the keypad events should also go into the 635 config GUI/file.;)

Using the keypad events as an example, a default module LED event sequence could be put in the module header section. If one wishes to change the LED's for a screen specific event, the info could be put in the screen header section, just like the screen-specific keypad events.

I realize that this would take some programming to do, but it would sure make the LED's much more useful and fun to program. It would be neat to use the LED's as a spectrum analyzer when using winamp.;)

As far as programming, the programming logic should already be there from the keypad code. Just substitute the LED code for the keypad code... I am sure this is simplification of the coding changes required ALOT:D

Just another thing to put on the wish list... Hopefully, this could be done.

Jim
 

jc634

Administrator
BTW, hopefully, I didn't throw a wrench into the works with this idea.

I was kind of bored (nothing new to break in CC2!:D ), and the idea just came to me...

Jim
 

MJancaitis

New member
Sorry for possibly bringing a thread back from the dead, but I just found this code and liked it. My situation, however, is this: CC2 is running full time. My processor currently runs full time at 100% due to running Folding@Home software. Due to that, all four LEDs are usually lit up a nice bright red telling me the F@H is still working. Every once in a while, however, the LEDs stop working, revert to just the one green LED at the top spot, and I have to restart CC2 to get them to work again. Everything else about the display still works properly, just the side LEDs quit. Any ideas? Thanks a lot, I love this code.

Edit: I've attached my ini files - as you can see, I've used the first of the four values in the perfmon as the values in the 635 ini.
 

Attachments

Top