• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

634 v2 scrolls gibberish.

Derek

New member
Hi, I just installed my 634 but am unable to get it working properly. I'm using Linux 2.2.18 with generic serial support enabled in the kernel (although extended and non-standard serial support is not enabled).

So far I've tried virtually every combination of IRQs and UART types using 'setserial.' I've tried LCDproc 0.4.1 and LCD4Linux, yet nothing but garbage ASCII scrolled on the screen. Using setserial, I made sure only /dev/ttyS0 (the LCD) had IRQ 4 and changed the baud rate to several different values. I even removed my ISA modem. Still no luck. Please help!


P.S. I noticed when /dev/ttyS0 is set to a free IRQ > 6, nothing's printed on the screen but a blinking cursor...LCDproc still won't work though (and has to be kill -9'ed).
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

CF Tech

Administrator
Please check to make sure the LCD and LCDproc are using the same baud rate. The v2.0 displays can be set to 19200, and it is likely that the default on the PC side is 9600.

You can either set the switches on the display to 9600 or set the software to 19200.

There is a small chart on the back of the LCD that shows the baud rate settings, or it is in the manual.
 
Top