• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

634 Serial LCD - Seemed to work fine until i saved EEPROM settings...

Bullwinkle

New member
I just got my replacement in from CS on an LCD that i fried. So now ive check all wiring. I've verified +5v on both the led and lcd +5v pads, and have hooked up a serial cable to my serial port. When i bootup i get the CS boot screen...i then launched boot configurator and was able to change what was being displayed. I got the screen to say what i wanted, then pressed the "Store all settings to EEPROM" (did this on the last lcd i had and it worked fine) .. i then did a "test (soft reboot)" and now i just get a flashing block/cursor in the upper left corner.

i reboot again and same thing...i get the CS boot screen (so i know it didnt save to my EEPROM) and then i get the cursor. At this point boot configurator doesnt work anymore either.

i've tried wintest and crystalcontrols too

now..if i switch it over to spi mode (which is the eventual application)..the app runs the lcd fine.

any suggestions on what to do to get my rs232 control back?
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad
Top