• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

634 doesn't work in Windows 7

rschissler

New member
I've tried everything I can think of and my 634 won't work in Windows 7. The screen lights up and I get the boot screen and then a blinking cursor. When I click on Configure CC2 I get an error message that says: "The requested operation requires elevation."
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

jc634

Administrator
I assume you mean you are trying to open the config program? What you need to do is highlight the shortcut for the program, click on properties, click on the Compatibility tab and make sure that the "Run this program as an administrator" box is checked.

This *should* take care of your problem.
 

rschissler

New member
That part worked. I was able to get the configure screen to come up. I didn't go any farther with this.

I have a bigger problem though. On a restart I get a blue screen and Windows 7 would not boot. It had to go to a System Repair to get Windows to finally start. Strangely, when Windows 7 is up there is a error message for Norton Internet Security. This whole sequence has happened several times and it seems the only solution is to unplug the 634 USB. Looking at Device Manager there is a yellow icon for Universal Serial Bus (USB) Controller. I tried updating the driver but it says "Windows could not find driver software for your device. On some other thread in the forum I saw about downloading some other USB drivers. I tried that, but it still says that it couldn't find the driver from the files in the folder I selected.
 

jc634

Administrator
What is so strange is that whenever I have installed Windows 7 and a CF display is that Windows has auto-downloaded the drivers everytime from Windows Update. In your case, have you allowed Windows to check the Windows Update for the drivers?
 

rschissler

New member
I do have a setting in Windows Update that is "Install updates automatically." It doesn't say anything about drivers.

Looking in the View update hisory I see this (I just did a copy and paste, but it added stuff here):

Crystalfontz - Other hardware - Crystalfontz CFA634-USB

Installation date: ‎9/‎5/‎2010 2:08 PM

Installation status: Failed

Error details: Code 80070103

Update type: Recommended

Crystalfontz Other hardware software update released in June, 2007

More information:
http://winqual.microsoft.com/support/?driverid=20123125

Help and Support:
http://support.microsoft.com/select/?target=hub
 

rschissler

New member
I got it working (sort of) somehow and was able to display a screen, but there are still problems. One thing I did was reinstall CC2.

First, there is something wrong with the system tray operation. All the boxes in Startup Options are checked, but to start CC2 I have to go to the Windows start menu.

Second, on a restart I got a error message from Windows: "CC2_tray.exe - Application error The instruction at 0x0824548b referenced memory at 0x082454b. The memory could not be read. Click OK to terminate" When I clicked OK, the restart began.

Third, when the computer does restart, I get the dreaded blue screen. So then I am back to unplugging the USB cord so Windows 7 will start.

Edit: Now whenever I restart: When Windows comes up I get a message box from CC2_configure.exe asking if I want to install a program (or something) from this computer.
 
Last edited:

rschissler

New member
I installed the new version of CC2 and most things are working, no Blue Screens Of Death, and no memory error messages or other messages.

One thing that isn't working is it doesn't automatically start when Windows7 is up after a restart or shutdown. The CC2 icon in the system tray is red and not running, and I have to click on Start CC2 to get my screen to load, and for the tray icon to turn blue.

In the General Options, all the Startup Options are checked. In the Start menu of Windows 7, Configure CC2 is set to Run as Administrator.

Any ideas?
 

rschissler

New member
I don't know if anybody cares, but I figured out how to fix the system tray problem I had. I noticed when I clicked on Customize in the system tray for hidden icons, that CC2 was listed as CrystalConrol2 NT Configuration. Then I looked at General Options from the CC2 Configuration and noticed that it had Run As... set to User Tray Application (default for Vista). I changed that to NT Service (default for Win2000/XP) and that fixed it. Now, CC2 runs on startup or boot and the icon in the system tray is blue and running.

Everything else seems to be working OK. What a huge relief.

Now, what about SpeedFan? I thought there was supposed to be a plug-in for it, but I don't see it listed?
 

CF Mark

Administrator
Changing it to "NT Service" will have some downsides if you are running Vista or Win7.

There is a SpeedFan plugin, but it isnt listed in the screen-editor.
If you hit the "Load Screen" button, youll find a directory with some pre-made SpeedFan screens you can use.

One problem though... one of the downsides i mention with using the "NT Service" with Vista/Win7 is that CC2 cannot get data from user-run software due to the security introduced with Vista :(
This means youll only be able to display SpeedFan info if CC2 is running as "User Tray Application".
 

rschissler

New member
Well that's a bummer. I guess that means Speedfan won't display to the device unless I start it manually from the System Tray. I don't want it to work that way, when the computer starts up I want to see it already working. Can't you tell Microsoft that it is OK? I found the user defined screens and can get them to work in the Configure window, but the data won't transfer to the device, only the static text.

I assume Coretemp, Winamp, etc. won't work either?
 

CF Mark

Administrator
That is correct :(

Working around the security issues pretty much requires a complete redesign/rewrite of CC2.
 

CF Mark

Administrator
No we are not :(
There is a chance that a new version of CrystalControl (CC3?) will be on the way at some point though to support future Crystalfontz products.
I have no idea when that will be.
 
Top