• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

634 Display 'not functioning'

VorTechS

New member
Hi all, I am generally new to the world of LCD modules - although I do have experience with programming Epson EPOS equipment including display pods so I'm not unfamiliar with them.

I bought 2 634 modules from 'the bay' and am struggling to make any of the test applications work with it.

I'm using a straight through, 9-pin serial cable and when no applications are running connected to the display, on initial cable connection the display shows a boot screen for a few seconds and then switches to a flashing cursor. I am not using any external power at the moment (as for now I do not need it backlit).

My PC port settings are as follows:



and I've modified the jumper settings for the port speed on the back of the module to reflect the appropriate speed.

Whenever I start one of the test applications, the application appears to connect successfully to the module ... forcing the display to be cleared but I cannot make anything else appear on the display.

I've tried using WinTest and CrystalControl2 and both applications, and both displays exhibit the same behaviour. I've also tried using a slower port speed (9600)

Help! What do I need to be doing to get the display(s) showing something different using the test apps?
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
Last edited:

CF Support2

Administrator
The powering up and boot screen changing to just a blinking cursor is normal behavior of the CFA634.

What is sounds like is that one or more jumper on the module have been opened / closed from the base configuration. The jumpers are labeled:

JPA
JPB
JPC
JPD
JPE
JPK
JPL

You can find the location and function of these jumpers on page 29 of the CFA634 datasheet:

http://www.crystalfontz.com/products/634/datasheets/342/CFA-634_v2.0.pdf

For standard operation, you will want the following configuration:

JPA - Open
JPB - Open
JPC - Open
JPD - Open
JPD - Open
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

CF Tech

Administrator
Something to check:

"Straight through" female-to-female DB-9 cables are not as common as the "null modem" ones. Are you sure pin 2 on one end goes to pin 2 on the other? A Radio Shack 26-152a will work (it is the same as our WR232Y01).
 

VorTechS

New member
Thanks for the reply. It was indeed an incorrect cable, I was using a Cisco router cable that I mis-understood to be a straight through cable.

It's all working perfectly now, thanks!
 
Top