• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

633 not sending response packets or keypad packets

cshcrystal

New member
I'm writing software for a 633 display.

So far I have the serial code working fine, and I've written an lcd library that can send packets to the display.

The display obeys the commands I send it.

However, it never sends a response packet, nor does it send a packet when I press a key on the keypad.

I have the manual that came with the unit and it doesn't say anything about disable/enable of command response packets, only packets from keypresses.

To read response packets, I have my serial routines reading into a buffer much like the example code that came with the LCD.

I even bypassed all of that by opening the USB serial port directly, and just outputting anything it received. It never receives anything from the display.

Is my display broken, or just misprogrammed somehow?

Any help appreciated.

Specs:

I have a Crystalfontz 633 TMC-KU with the USB->serial interface circuit. It was ordered without the ATX power cable, and I'm not currently able to give you the on-board ID information because as I said, I can't get it to respond.

I am using FreeBSD 6.2 to talk to the unit with /dev/ttyU0, and as I said, sending commands to the unit works perfectly, it simply never returns a response packet.

I have tried reading them directly with a read(fd,buf,N) call specifically after sending each command, using a loop and a delay to give it plenty of time. I've waited as long as 30 seconds and repeatedly sent commands, it never responds.
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
Last edited:

cshcrystal

New member
more info

I booted a Windows box and ran the test software, and there the 633 unit I have worked.

Not that it helps me much in figuring out what is going on with FreeBSD, but it would appear at least the 633 is working.

When I send a packet under FreeBSD I basically create the packet, call my lcd_sendpacket() function, which then sends the packet and the CRC.

This part works fine.

When I call the routing to read from the serial port, it never finds any data waiting.

I used the same serial port setup as the Linux demo program that Crystalfontz sent to me written by "Brent".

The only thing I can think of is this is something odd about the USB serial device.

Again, any help appreciated.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad
Top