• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

632 (USB) has gone all brackets

kronchev

New member
Hi all,

I have an inverted 632 USB that I have had for, I guess 4 years at least. It worked fine when I had it out and running, no problems. Recently I pulled it out to mess around and have discovered that the only output I can get out of it is this:

}

Over and over and over. I've tried it with both LCDSmartie and the boot screen editor, nothing can change what it shows, the Test (Soft Reboot) button does nothing to the LCD. When I first plug it and do nothing it shows the correct boot screen.

Cable looks fine, params are all set correctly, I'm at a loss.
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Tech

Administrator
Does the baud rate shown on the boot screen match the baud rate set in your program?

Can you try WinTest just for kicks: http://www.crystalfontz.com/product/WinTest

When using WinTest, can you verify that each character you send gets converted to a corresponding '}' ?

Can you verify that JPA is OPEN, JPB is OPEN and JPE is OPEN?
 

kronchev

New member
The bauds rate do match

Things sent using a demo on Wintest are turned into all kinds of different characters depending on the test, for instance Bar Graphs produces a string of chars, }'s included but there's also ?, |, à, and É, while Scrolling Banner throws out a different single character every time I press Go.

However sending individual characters is more confusing, it shows a bracket after an arbitrary amount of sent characters, as in it's different every time, I got a bracket from 5 a's and the next one took 20. All letters and numbers trigger one after enough input has been sent.

JPB and JPE are closed, and I they came that way. I have never touched any of those jumpers.
 

kronchev

New member
If you are hooking it to a PC, JPB and and JPE should be open. Please try opening them.

It must have been configured for "inverted logic level" (typically used in embedded systems to connect directly to the microcontroller's UART pin) at some point, possibly here at the factory.

Why would this only be a problem now? I did have it running for a long, long time hooked to my PC years ago and it worked great.
 

CF Tech

Administrator
JPB and JPE should be closed on a USB module, as they are.

I am not sure why it is not working.

We can arrange an RMA to find out what is going on if you would like.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad
Top