• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

632 not working

richk449

New member
I recently recieved a 632 LCD. It doesnt appear that there is any damage to the unit, and it appears to have been shipped properly, but it does not work. I cannot get anything to appear on the LCD, or the backlight to come on.

I have tried everything I can think of. I have tried it on two computers, with multiple serial cables, in multiple serial ports (including ones that I am certain work properly). I have tried WinTest, and CrystalControl, at different baud rates. I have tried it under linux with the sample code provided by Herbert Rosmanith (properly modified, of course).

Does this mean that I have a bad unit? Is there anything else I should try? What should I do if my 632 is bad?

Thanks,
Rich
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

richk449

New member
null modem / straight through

i was concerned about this, so i bought a brand new serial cable. it was the only type they had at compUSA. it was labeled "serial cable." it does not specifically say "straight through" on it, but it also does not say "null modem" or anything implying that it is used for cross over. i can try buying another type online, but i hate to keep spending more money on cables if they are not the problem.

So is there anything else I can try before I spend more money on cables? Or would you say I am down to a bad unit or wrong cables?

thanks for the help,
rich.
 

CF Tech

Administrator
If you have an ohm meter you can test your cable. If pin 2 on one end goes to pin 3 on the other then it is a null-modem cable, and will not work.

If pin 2 goes to pin 2, then it is a "straight through" or "extension" cable and should work fine.

A radio Shack Cat No 25-152a works fine.
 

richk449

New member
null modem / serial cable

okay, i found the solution:
I am a moron.

I put the serial number of my cable in on Belkin.com, and it turns out that I have a null modem cable - even though it was not labeled that on the package.

so, i will get a new cable, and try again.

thanks for all your help,
rich.
 
Top