• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

631 stops and shuts off

T1125P

New member
Hi all, I noticed after I installed this windows update : FTDI - Other Hardware - Crystalfontz CFA631-USB my LCD stays on for a few mins then turns off, then soon after its completely off. I have tried system restore but it says it could not be completed which is weird. Does anyone know how to manually remove this update? Its not in the add/remove programs :confused: I also reinstalled the software and its still the same
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

jc634

Administrator
You updated your drivers from Windows Update? If so, you *may* be screwed. I tried this once with very bad results. I was able to find the driver files (search ft*.* in your Windows directory), but I think there may also be entries in the registry that I did not look for.

I *believe* that these are the FTDI v2.00 drivers. If so, I would make 1 suggestion before nuking your system (which is what did):

Download, install, and update your drivers with the drivers I made from the FTDI v2.00 generic drivers. I have tested them in XP and Vista (32-bit only), and they do work. IMO, better than the current official CF drivers. You can grab them from:

https://forum.crystalfontz.com/showthread.php?t=5104

No guarantees, but I *think* that this may take care of the problem. AT least it won't hurt to try them.

Jim
 

CF Tech

Administrator
CF Support is working on getting the 2.0 drivers modified and signed. I guess that may have happened, and they were what got downloaded. I'll ask him to chime in on this thread.
 

T1125P

New member
Ok I tried that jc634 but it still shuts off. Is there any way to delete all usb drivers from the registry for the 631? Or I guess I will wait a few months until I upgrade to vista to do a complete reinstall.
 

jc634

Administrator
Question: did you update the drivers or uninstall the old ones? I'm not sure it would make a difference, but it is worth a shot.

If you follow the instructions in the download from the aforementioned download, you should be able to uninstall the 631 module and also the drivers when you do so.

This would be a last ditch effort, except for: You could try to search for the drivers, as I suggested in my previous thread, also. And if you really feel brave, you could try to edit the registry. Search for items link Crystalfontz, Crystalcontrol, 631.

Only do this if you really know what you are doing.

Or you save your data files and reinstall XP. I've done that so many times, that I finally had to call MS each time to reactivate XP!:p

Jim
 

T1125P

New member
Ok thanks I'll try again. Should I also uninstall the crystalcontrol software? Then what comes first USB drivers or crystalcontrol software?

thanks
 

jc634

Administrator
It wouldn't hurt to uninstall CC2. You could save your ini files elsewhere, if desired. Unplug your 631.

Then:

1. Delete any files you have in the Crystalfontz USB Drivers directory.
2. Copy the new files into this empty directory.
3. Connect your 631.
4. When Windows prompts you for drivers, do a manual install and browse to that directory.
5. Install CC2.
6. Etc....


Hopefully, at this point, everything should work. You might want to try Wintest prior to installing CC2, if desired.
 

T1125P

New member
jc634 what I did now was just reinstall the FTDI v2.00 drivers, and not the crystalcontrol software. The LCD has been on for over 90mins without turning off. Now I think it could be the software, I'm going to go back to the earlier version of crystalcontrol and test it.
 

jc634

Administrator
If you have a copy of Wintest, try that first. Just to make sure that HW and drivers are working OK. If everything keeps working OK, install whatever version of CC2 you wish.

If that works OK, copy the CC2 dircetory to a safe location, install the latest version and see how it goes. If it goes south, just stop the CC2_service and CC2_config. Delete everything from the CC2 directory and copy back your "saved" copy.

Jim
 

T1125P

New member
Ok I found out that its the crystalcontrol software that makes my lcd shut off. I been using lcd smartie now for hrs and my lcd is fine. But I like crystalcontrol so much better. Oh well guess I have to see whats the conflict.
 

jc634

Administrator
If you really want to try CC2 again, install it, add a couple screens.

If it goes South, zip up the log files and upload that file here. Perhaps I or CCadmin can figure out what is happening.
 

T1125P

New member
Hi, it just stopped again, where are the log files? I have a text file that says unknown, not sure if this is it.
 

jc634

Administrator
Hi, it just stopped again, where are the log files? I have a text file that says unknown, not sure if this is it.
Should be 20 or log files. cc2_*.log plus one for the lcd module, i.e. lcd_631.log.

If there are none there, that would be weird. What is in your logpref.ini file?

Jim
 

T1125P

New member
this is my logpref.ini

; CC2 logging levels
;
; LOG_DEBUG 0
; LOG_NOTICE 1
; LOG_WARNING 2
; LOG_ERROR 3
; LOG_CRITICAL 4

[logging]
console_level=2
file_level=2
system_level=3
 
Top