• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

631 randomly shows boot screen

Mercury

New member
I've been having a weird problem with my 631. It started happening after I did a full reinstall of XP, though I'm not sure if it's related or just a coincidence.

I have my 631 displaying various stats (I usually have it sitting on one screen reding out speedfan temps). I also have the brightness and contrast turned down (25% and 20% respectively). At random times, the contrast and brightness will go back to full, and the boot screen will show. The parts that are supposed to be updating (the temps) will keep updating, but all static text is replaced with the boot screen text/logo. This also happens with any other screen I've tried.

If I cycle the screen, it will change and display correctly, but the brightness and contrast will still be at max - which looks like crap with the lighting in my room.

This problem used to persist until I restarted CC2, but with the newest CC2 release it fixes itself after about a minute, contrast and all. Although it's a major improvement I wonder whether I can do anything to fix it completely.
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.
 

CF Tech

Administrator
CC Admin and I have discussed this, and we think it must be a hardware issue.

If the power to the CFA-631 is interrupted, it would reset, but the only other way to get to reset is a "reboot" command which would be almost impossible to send by accident.

Is there any chance that the connection to your display is intermittent (loose cable, flakey USB hub, etc)?

If you do not think that could be the problem, then we can arrange an RMA.
 

Mercury

New member
I'm pretty sure all the connections are good, but I'll recheck them. At this point I don't think I want to bother with an RMA, although I'll consider it if it gets any worse.

The time until this "reset" seems to average about an hour, but I've seen it happen as quickly as five minutes and as long as six hours. Like I said, it seems to be completely random, it doesn't matter if I'm using the computer or not or what programs are running.

Since it now fixes itself in less than a minute, I've only seen it happen twice so far in the last four days, but there were probably other times when I simply didn't notice. All things considered, I think I can live with it, though I was hoping it was a software bug.
 
USB LCD Displays - Graphic and Character LCDs with a Keypad

Mercury

New member
It seems to be doing something slightly different now.

It will now randomly show the boot screen (with contrast and brightness at full) and nothing I can do will fix it unless I reboot, whereas previously I could just restart the service and all would be well again. It's also completely nonresponsive to the buttons.

More interesting is the fact that once this happens, I can't stop the service. If I try to stop it (or restart it) through the config app, it will simply say "Stopping..." for as long as the computer stays on.

I've rechecked all the connections and re-downloaded and reinstalled the USB drivers and CC2.

I'm not sure if this is related to the same problem as before.

Would a hardware problem cause the service to lock up?
 

Mercury

New member
Here are my log and ini files from today. The LCD worked fine for several hours, then I noticed it was back on the boot screen. I waited a few minutes before trying to stop the service, then waited a few more minutes before zipping up these files.

It seems the service locks up on "unloading plugin "lcd_631.dll"..." as that is the last entry in the log. This only happens if the LCD is showing the boot screen. If it's working normally, the service stops without any issues.

Final verdict: Hardware or software problem?

I really hope it's not the hardware as sending this thing back would be a major PITA.
 

Attachments

Top