CFA-533 I2C on Raspberry Pi zero


New member
Hi Hello,

I am having trouble talking to the CFA-533-I2C device.
I am using a RPI zero w card running RPI OS.
The attached code is not working for me.
I can see the device with the i2cdetect -y 1 command at address 0x2a.

I looked at the code in the but I do not have access to the AVR Studio program which is Windows only.
If I try and compile the CFA-533-I2C-AVR code I get undefined variables like TWEN or TWCR, so I tried writing my own code and it is attached.
I do not get any errors when I run the program but it fails to clear the screen.

Can someone look at my code and tell what I am doing wrong?
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.


USB LCD Displays - Graphic and Character LCDs with a Keypad

CF Kelsey

Staff member
Glad to hear you got it working!

For anyone with similar problems in the future, the Arduino IDE is the AVR compiler we use and is available for Windows, mac, and linux.

We also have this tutorial for using a CFA533 with a raspberry pi: