• We recently switched our forum platform. If you experience any issues please email support@crystalfontz.com

Can't run as administrator - Vista64


New member
I've been trying to run CC2 config as admin and then setup the task scheduler per the instructions on this site. The task is set and running, but I still get the "was not run with adminsitrator access" warning. I know I've got to be doing something incorrectly, or have some Vista setting wrong, but haven't been able to figure it out. Would appreciate some help- thanks.


Standard screens like time, date, CPU usage work.
Looking for additional LCD resources? Check out our LCD blog for the latest developments in LCD technology.


Most sure way is to open up Windows Explorer, and go to the C:\Program Files (x86)\CrystalControl2 directory.

- Highlight cc2_config.exe
- Right-click over it
- Click on the Properties item
- Click on the Compatibility tab
- "Check" the Run this program as an administrator box
- Click on OK button

You should be good to go.


New member
Did that, restarted CC2, opened and clicked "Add New Screen"- still get the run without admin access warning. I've been reading that the behavior of the 64 bit version seems to be different than the 32 bit version is some areas, especially relating to drivers. I wonder if this is related.


(too much enthusiasm, not enough research into 64 bit OS:confused: )


New member
Got it! It had been set up correctly. All I had to do was remove the CC icon from the system tray, and restart the program from the Start menu. This time, the icon placed in the System tray was run with the admin access applied. The original icon (put there during install) did not, nor did it's properties get updated when I changed them. After removing it and restarting the program, I can now access the config screen from the system tray icon with no warnings.

Thanks :D